This question is about the new profile page as now visible only here on Meta Stack Exchange.

In the 'Edit profile & settings' tab, you can set your Stack Overflow Careers link. I have three questions about this:

  1. The input is called "Stack Overflow Careers link", but when you enter crap, the message says:

    The Stack Overflow Careers link or username entered does not appear to be a valid Stack Overflow Careers link or username.

    It's unclear to me if a username is OK as well, and what I should use as my username (my email? My id?)

  2. Not a question, but a bug: my id as a number is accepted, but the link generated, https://careers.stackoverflow.com/260375, gives a Page Not Found.

  3. I can't find any link that is accepted and works. These are all not accepted at the moment:

    What am I supposed to enter here?

  • It's 404 not found because you set it to Private, which is also the default. Commented Feb 23, 2015 at 18:49
  • @ShadowWizard this is not true, see careers.stackoverflow.com/camilstaps. It's like this because that URL isn't designed to work like that (which I just learned).
    – Keelan
    Commented Feb 23, 2015 at 18:49
  • Hmm... weird, probably it's not designed yet to get the id then. Commented Feb 23, 2015 at 18:50

1 Answer 1


It's looking for your public URL slug, either as a full link or just the user-entered bit, i.e.


or just


in my case.

This is configured via the privacy settings in your Careers profile, accessible via the edit view sidebar:

edit view sidebar

You need to create this to make your profile public, which is an implied prerequisite of linking it from your profile.

The validation on the field is obviously not checking that the URL is actually registered on Careers, which might be a nice-to-have, but in lieu of that it should probably be a bit clearer about how that process works (maybe by linking to the privacy settings page on Careers directly).

  • Alright, that makes sense! Didn't know about the existence of that slug.
    – Keelan
    Commented Feb 23, 2015 at 18:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .