3

When using the Stack Exchange App for Android, I encountered a problem when uploading multiple images to the same post.

After uploading a single image, the image Markdown is inserted normally, e.g.:

![enter image description here][1]


  [1]: http://i.stack.imgur.com/Cbh1m.jpg

As I upload more images, the list of URLs at the bottom of the post should be appended to. After uploading the above in a new post, I tap to place the cursor at the end of the first line, enter a newline and the toolbar reappears. I then upload a second image with this result:

![enter image description here][1]
![enter image description here][2]


  [1]: http://i.stack.imgur.com/Cbh1m.jpg
  [2]: http://i.stack.imgur.com/V5nXV.jpg

Now I edit the image descriptions, to make sure I can keep track of all my images, place the cursor at the end of the second line and enter a newline. The edit box contains:

![a black circle of utter blackness][1]
![the best planet earth clip art ever][2]



  [1]: http://i.stack.imgur.com/Cbh1m.jpg
  [2]: http://i.stack.imgur.com/V5nXV.jpg

I then upload a third image. What's interesting is that as the screen reloads, for an instant I see the best planet earth clip art ever replaced by more image markup, so the second line is this:

![![enter image description here][2]][2]

But only for a moment. Then the screen updates, and the edit window is left in this state:

![the best planet earth clip art ever][2]
![the best planet earth clip art ever][2]
![enter image description here][3]


  [1]: http://i.stack.imgur.com/Cbh1m.jpg
  [2]: http://i.stack.imgur.com/V5nXV.jpg
  [3]: http://i.stack.imgur.com/6Ra5w.jpg

I correct the first line and insert a line break after the third line in preparation to upload the first image again (I really love blackness). Before uploading, the edit window looks like this:

![a black circle of utter blackness][1]
![the best planet earth clip art ever][2]
![a fast computer][3]



  [1]: http://i.stack.imgur.com/Cbh1m.jpg
  [2]: http://i.stack.imgur.com/V5nXV.jpg
  [3]: http://i.stack.imgur.com/6Ra5w.jpg

After uploading:

![a fast computer][3]
![the best planet earth clip art ever][2]
![a fast computer][3]
![enter image description here][4]



  [1]: http://i.stack.imgur.com/Cbh1m.jpg
  [2]: http://i.stack.imgur.com/V5nXV.jpg
  [3]: http://i.stack.imgur.com/6Ra5w.jpg
  [4]: http://i.stack.imgur.com/ILUCC.jpg

Now, instead of adding a newline, I position my cursor at the end of the third line. The toolbar isn't visible so I insert a space and then delete it. I upload another copy of the third image from this position adjacent to other image markdown, and now the result is:

![a fast computer][3]
![the best planet earth clip art ever][2]
![a fast computer][3]![enter image description here][4]
![enter image description here][4]



  [1]: http://i.stack.imgur.com/6Ra5w.jpg
  [2]: http://i.stack.imgur.com/V5nXV.jpg
  [3]: http://i.stack.imgur.com/6Ra5w.jpg
  [4]: http://i.stack.imgur.com/jG0fk.jpg
  [5]: http://i.stack.imgur.com/ILUCC.jpg

Notice:

  • The new image, the fifth I have uploaded, goes in as image [4]. Not a problem, so far, but:
  • The previous image description is still linked to image [4], now a different URL; and
  • The first URL in the list has been overwritten by the URL of the third image, which happens to be immediately adjacent on the line where I inserted the most recently-uploaded image.

Reproduced at the time of this question revision, with the following specs:

  • Device: Moto G 2013
  • OS version: 4.4.4
  • App version: 1.0.57
  • Thanks for reporting this! Looking into it... – Kasra Rahjerdi Feb 26 '15 at 18:28
  • 1
    Thank you for the reminder. I have just reproduced the issue and added the steps taken and app version. – Air Feb 26 '15 at 19:18
1

This will be fixed in 1.0.84.

The problem and solution are described in this answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .