6

In a thread on meta stackoverflow I noticed that it is possible to set up to be notified to responses to a post via email by checking a check box. However I am not seeing the checkbox when attempting to make a new post and I have tried stackoverflow, meta stackoverflow and meta stackexchange. I am using chrome 40.0.2214.115 m and see the following when I try to make a new post. I have also checked in Firefox 35 and I don't see the checkbox there either. I am using Google as my openid provider if that makes any difference.

The post on meta stackoverflow has the following image

Here is my email settings (note I blanked out the email address that was in there to hide it)

enter image description here

4
  • Just for info: I shot that picture (with the redcircle) with a brand new account on firefox but with my own account I see the box as well in Chrome and in IE11.
    – rene
    Mar 6, 2015 at 17:42
  • @rene I have updated the post to include a screenshot of my email settings
    – Joe W
    Mar 6, 2015 at 17:51
  • So, you had everything checked before (as in the screenshot you showed) and hadn't received any emails?
    – nicael
    Mar 6, 2015 at 17:52
  • @nicael Everything but the address was as shown and I did not see the option to be receive new responses via email as shown in the second screenshot that was provided by rene. As for in general receiving emails I generally check all notifications via the android app so there should be nothing to send daily.
    – Joe W
    Mar 6, 2015 at 17:55

1 Answer 1

7

The "send me new responses to my posts via email" is the exact same feature as "email me my unread inbox messages". Because the email settings are buried pretty deep in your profile, we wanted to surface them in the context where they probably matter most to the majority of users: when you're asking a question (which someone might answer) or posting an answer (which someone might comment on). The idea behind the checkbox there is to let users know that we can notify them of new answers without them having to come back and check the site. That checkbox is only be shown if the user has not opted into receiving unread inbox messages via email. Since you are already opted into those emails, you don't see the checkbox on the ask question page or when posting a new answer.

If you're checking your notifications in realtime via an SE app, there won't be any emails to send.

Sorry for the confusion. Everything is working as it should here.

1
  • That explains it, was confused why some people had that check box but I did not. I did understand why I didn't the emails as I was checking enough that there would not be anything to send more confused as to why not checkbox.
    – Joe W
    Mar 6, 2015 at 18:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .