This is the same as this answered question, except I've tried the steps outlined there and it didn't work.

I first logged in using my Google log-in and then tried association, but I'm still referred to as New User and there doesn't seem to be any association with StackOverflow. So I resigned in with my OpenID after logging out and clearing cookies and tried associating that way, and it tells me the account is already associated.

Any ideas?


If the association was working properly, logging in with either Google or OpenID should go to the same account as they do when logging into SO, but they do not. Something is screwy.

I see "No associated accounts" when I click "New User" but I can't associate my account (in either log-in - which, if associated properly, should surely both lead to the same careers account anyway as they would link to the same account in SO, Meta, SF or SU).

  • 1
    Having the same issue. – Daniel May Oct 8 '09 at 13:01

If the association was working properly, logging in with either Google or OpenID should go to the same account as they do when logging into SO, but they do not. Something is screwy.

The careers account is indeed created as new, and then you use the associate tab to associate your SO account with your careers account.

The matching of SO account to SOC account is done via openid after you've created a new SOC account. It does not change any information in your SOC profile; they are totally independent sets of data. All it does is make the change you can see on the View CV tab.

If you can't associate email the address at the bottom of every SOC page for assistance.

  • Thanks, I'll try the e-mail. :) – Jeff Yates Oct 9 '09 at 15:13
  • We got Jeff Yates all sorted out. – Jarrod Dixon Oct 15 '09 at 9:03
  • Thanks, guys. Great job. – Jeff Yates Oct 15 '09 at 12:42

You need to fill your real name for it to appear where New user is

  • @Juan: So what good does association do? It doesn't even drag in your SO profile? – Jeff Yates Oct 8 '09 at 13:07
  • 2
    I don't think it's intended to drag in the SO profile. I'm relatively sure Welbog wouldn't want his profile text visible to employers, ha. – Daniel May Oct 8 '09 at 13:19
  • @Daniel: Fair point. But surely, the logins associated to my SO account should all log-in to the same careers account. They don't. – Jeff Yates Oct 8 '09 at 13:27
  • This doesn't address the core issue that my account isn't associated but I can't associate it because it complains it is already associated. – Jeff Yates Oct 8 '09 at 13:50

Are you entirely sure you're using the same OpenID for SO Careers as you are SO?

You should have a small button to press saying Authenticate with Stack Overflow on the Associate Accounts tab - Have you seen this yet?

  • Definite. I first logged in with my Google account (as associated with SO account). It didn't have the associate button. So, I logged in with my open ID account - it had the associate button but refuses to let me associate because it says it is already associated. Neither log-in has any associations declared though and both those log-ins would take me to the same SO account. – Jeff Yates Oct 8 '09 at 13:48
  • So - let me get this straight - it's saying it's already associated, but when on the Associate Accounts tab, there's no flair box (name, rep, etc) in it? – Daniel May Oct 8 '09 at 13:57
  • Okay, so when I log-in with any account I have, it tells me "No associated accounts". When I try to associate, it says it cannot because it is already associated. The associated SO box does appear on the linked accounts page along with the text along the lines of "You haven't associated any accounts". Somewhere, there is a bug. Either it is associated but thinks it isn't, or it isn't and won't let me. – Jeff Yates Oct 8 '09 at 15:27
  • Definately sounds like a bug then - hopefully someone'll be along soon. – Daniel May Oct 8 '09 at 15:43

I noticed yesterday when I signed up that it took a minute or two for "No associated accounts" to change. I assumed there was some sort of caching going on, and that the act of associating the account did not invalidate the cache.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .