5

I am using GNU IceCat 31.2.0 on Trisquel GNU/Linux.

When I tries to login into chat, http://stackexchange.com/users/chat-login brigs me to http://chat.stackexchange.com/login/global-fallback.

I've tried following things but no success:-

  • Disabled HTTPS Everywhere
  • Cleared all history, cache etc:

    screenshot

  • Allowed pop-ups for [*.]stackexchange.com & stackauth.com:

    screenshot2

    (Please tell me if there are other settings (like by using about:config) for cookies or data exceptions.

Let me tell you that currently I've not enabled any extra privacy features (All Unchecked):

privacy-features

Status from http://chat.stackexchange.com/help:-

screenshot3


I've also visited similar questions but still no success. (Before closing as duplicate, give/link me answer containing solution that work for me!)

How can I fix this issue?


Note that I am surprised when found meta chat login working fine instead of normal!!

  • 1
    I fear there's no solution - SE can't possibly support all browsers. Use a common browser. – ShaWiz Mar 16 '15 at 7:16
  • OK. I found one epiphany-browser : (Intuitive GNOME web browse) available on Trisquel's repository which is working excellent and I can successfully login to chat through it! – Pandya Mar 17 '15 at 13:34
  • Well, don't be surprised if other things suddenly break... – ShaWiz Mar 17 '15 at 15:22
  • @ShadowWizard I've not found any break yet. (What type of sudden break you are warning about?) – Pandya Mar 18 '15 at 13:58
  • Good for you... dunno what might break, just a friendly warning so that you won't be surprised - it might be as minor as some pixels mismatch, or as major as failed login. No idea why you're so against common browsers, but that's not my place to judge. – ShaWiz Mar 18 '15 at 14:51
  • OK, BTW I am not against common browsers, I am with free software. (probably against with proprietary software) – Pandya Mar 18 '15 at 15:06
  • 2
    Same problem with Debian’s Iceweasel. – unor Apr 18 '15 at 1:44
  • @unor Which OS? – Pandya Apr 18 '15 at 10:33
  • @Pandyan: Debian ;-) It’s Debian’s version of Mozilla Firefox without the trademarked parts (same idea like GNU IceCat, but a different project). – unor Apr 18 '15 at 13:44
  • +1 here - Iceweasel on current Debian Testing. I'll be direct: Do these meta questions reach people who are working for SE and in a position to provide some technical insight into the problem - this might after all be something that can and has to be fixed browser-side - or is this like many support forums that have been outsourced to the user community, where things like "have you restarted the application/your computer" are the most common answer and thread-ender? – Michael Schumacher Jul 1 '15 at 17:08
1

Today when I tried to login chat-room, I found this issue fixed.

Now I can successfully use chat-rooms of chat.SE as well as chat.meta.SE on GNU ICeCat.

So, I am superseded and while chatting found what is going on:

Visit Upcoming login changes (Stage 2 now LIVE) for further information.

Quoted Information:

What this means right now:

  1. When you log into any Q&A site on the stackexchange.com domain, you will be automatically logged into all other Q&A sites on the stackexchange.com domain + stackexchange.com itself.

    • Area 51 is excluded from this.
  2. stackoverflow.com, superuser.com, and other Q&A sites with their own domains will still use the old flow.

  3. We are going to recognize you in some ways on sites where you don't have a profile. This is still a work in progress, but most notably you will see "join this community" in the top bar instead of "sign up" and "log in".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .