3

Relates to: https://meta.stackexchange.com/a/216394/269660

Despite all efforts, I seem not to be able to login to meta.mathematica.stackexchange.com, even if already logged into mathematica.stackexchange.com.

If I click on "log in" from any meta-page, the then-current page just reloads, but no login page is shown.

This happens with Firefox 36.0.1 (and earlier versions, too), even in "Safe Mode", but then again the browser should not be the reason for my problem, since it works flawlessly within other stackexchange sites regarding login.

I would appreciate any help in that matter.

3

After having cleared every cache, history, … I was able to log into meta.mathematica.stackexchange.com, alas: After having revisited mathematica.stackexchange.com, I was not logged into meta anymore. :(

This happens for every subsite-meta.

After some experimenting, I found a real workaround (and the underlying reason for this very odd behavior):

Workaround

I had to disable the rules for stackexchange in the "HTTPS Everywhere" plugin by the Electronic Frontier Foundation. Now, logging into meta.mathematica.stackexchange.com works flawlessly:

HTTPS Everywhere Configuration Dialog

Reason

The plugin itself is not the real reason behind this, but the fact, that while https://mathematica.stackexchange.com has a valid SSL certificate, https://meta.mathematica.stackexchange.com does not!

When trying to log into meta.mathematica.stackexchange.com (or any other subsite's meta), this leads to the observed problem, since HTTPS Everywhere tries to enforce usage of the encrypted connection. Possibly, there is also a bad redirect URL somewhere within the login mechanism, specifying http or https explicitly, which it shouldn't, but I did not explore this further.

Since this happens with meta..stackexchange.com, but not meta.stackexchange.com, I suppose this might be a subdomain restriction problem of the site's SSL certificate.

This is known to SE already and not a browser issue at all.

  • Ah yes. I should've asked if you were using HTTPS Everywhere. Good catch. :) – Adam Lear Mar 20 '15 at 17:45
2

We occasionally see weird behaviour from Firefox when it comes to login. Try clearing your cookies/cache. If that doesn't help, also try clearing the browsing history for that site. (It sounds unrelated, but for some reason tends to help.)

Let me know if that doesn't get you going and we'll dig further.

  • I clear everything and get to the login page on meta now, but: After logging into meta via OpenID, I am still not logged into meta.mathematica, but mathematica. – Jinxed Mar 17 '15 at 18:21
  • Worse yet: Clicking on "log in" in meta gives me the non-meta-mathematica login page. – Jinxed Mar 17 '15 at 18:23
  • That's normal. All child meta authentication is routed through the main sites, so you should be seeing a login page from mathematica, not meta.mathematica. Try this: clear cookies, cache, local storage, browsing history for meta.mathematica, mathematica, and also stackauth.com. – Adam Lear Mar 17 '15 at 18:24
  • I already cleared everything and tried Safe Mode. – Jinxed Mar 17 '15 at 18:36
  • Hey! Wait! Suddenly I am logged in! What I did: Clear everything (again), then restarted the browser (which I didn't before), and voila! it finally worked! Thank you! – Jinxed Mar 17 '15 at 18:41
  • @Jinxed Glad to hear it works now. :) – Adam Lear Mar 17 '15 at 18:59
  • Please check my own answer. There seems to be a problem with the SSL certificate and/or the login redirection code itself (fixed protocol in target URL e.g.). – Jinxed Mar 20 '15 at 7:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .