6

A couple of days ago everything worked perfectly on my chrome, today I only see the tex source of all the math formulas, I have no clue why. I did not change any settings, maybe I've updated my chrome like a week ago. How can I fix this?

12
  • Maybe MathJax client side library is blocked on your side. What you see when browsing directly to cdn.mathjax.org/mathjax/latest/…? Mar 19, 2015 at 7:15
  • @Shadow: It says This webpage is not available.
    – domotorp
    Mar 19, 2015 at 7:26
  • Try with a different browser to check if it's browser issue or global block on your side, e.g. proxy/firewall/ISP. Mar 19, 2015 at 7:50
  • 1
    @Shadow: Now after I've refreshed, it works again. Before I had also tried refreshing, but then it was no help. I leave the question here as it's an issue that others might have and it would be nice to know how to fix.
    – domotorp
    Mar 19, 2015 at 8:59
  • 1
    Now cdn.mathjax.org is down, at least when accessd from my area (Czech Republic). Only LaTeX source displays on Mathematics. Maybe they have problems lately.
    – Palec
    Mar 22, 2015 at 18:14
  • Fwiw, it works from NY USA. @Palec do a traceroute maybe?
    – Jason C
    Mar 22, 2015 at 18:21
  • @JasonC Obviously it’s not just my problem. In this test, Asia is OK, Europe and US time out. monitis.com/traceroute/… In my area, the hostname fails to be resolved.
    – Palec
    Mar 22, 2015 at 18:34
  • 1
    @Palec Maybe some DNS changes somewhere? In which case it should fix itself at some point in the near future. I wonder if it works if you change your DNS servers to 8.8.8.8 or something. Just out of curiosity, what is your current primary DNS server?
    – Jason C
    Mar 22, 2015 at 18:35
  • @JasonC $ dig cdn.mathjax.orgconnection timed out; no servers could be reached, $ dig cdn.mathjax.org @8.8.8.8 → no answer section. But a minute after it caught up and now both Google and my DNS return correct results and MathJAX on Math.SE works.
    – Palec
    Mar 22, 2015 at 18:42
  • And here we go again. The same problem.
    – Palec
    Mar 22, 2015 at 19:14
  • Now I noticed your question about primary DNS server, @JasonC. I resolve using my TP-LINK Wl841N router, it uses the resolver of my ISP. What goes next? Who knows…
    – Palec
    Mar 22, 2015 at 21:01
  • Repro is Ohio. isup.me seems to agree it's down
    – bjb568
    Mar 24, 2015 at 22:08

1 Answer 1

6

Ah, it looks like a concrete answer has been given over at Math's meta by Peter Krautzberger:

Peter from the MathJax team here. Our CDN provider has been experiencing attacks on some of its DNS servers (see also this thread on the MathJax User Group).

This attack leads to erratic DNS resolution failures. We're sorry for the inconvenience this is causing users and we'll send out an update as soon as we get any news.

1
  • 2
    Thanks for cross posting and sorry for not catching this post here last week. Sorry for the inconvenience everyone! We hope the attack will be mitigated soon. Mar 24, 2015 at 22:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .