9

Uhm, I have no clue where to start, but something really weird has happened in the last few hours.

  • I have one active Stack Exchange account I use on multiple sites. That's this one.
  • I only use the Stack Exchange login, no Google or Facebook.
  • I had a problem changing my e-mail address ages ago. (No clue if that's related to this issue.)
  • I logged in to Stack Overflow earlier today without any problems.
  • I tried to get on Super User (for the first time) with my usual credentials. I got in, but it didn't show my other accounts?
  • I deleted my logins. (Maybe that's the problem? I don't know.)
  • I went back to Stack Overflow, logged back in and was asked to create a new account?!
  • I went here to find out that all my accounts are still there.

If you click my profile here, you'll see a 5k rep user on Stack Overflow:

https://stackoverflow.com/users/1329111/sherlock

However, if I log in on Stack Overflow with the same credentials I used moments ago to log in here, I end up with this user:

https://stackoverflow.com/users/4713737/user4713737

I searched, but didn't find any issues that could help me. I'm lost.

  • 1
    Wait what ... I just logged out from SO, waited a few seconds and the system logged me in automatically to the right account. – Sherlock Mar 25 '15 at 19:44
  • But when I log in manually in a new private tab, I end up with the new user instead of my own old one. – Sherlock Mar 25 '15 at 19:45
  • 2
    "I deleted my logins." - if you're having trouble accessing your account or you see something weird, this is probably the worst thing you could do. Just... why? (Hold on, don't touch anything else. I'm looking into what is going on here.) – Adam Lear Mar 25 '15 at 19:46
  • Because I expected to see my normal accounts on SuperUser and didn't see them. I figured 'delete login' kind of means clearing sessions or whatever. It didn't come across as such a destructive move. – Sherlock Mar 25 '15 at 19:47
  • Woah, you fixed it. Thanks for that. – Sherlock Mar 25 '15 at 19:55
6

I tried to get on Super User (for the first time)

Your original account has a Super User profile associated with it that's about 2 years old. Are you sure you've never been on Super User before? :)

It's unfortunately difficult to reconstruct exactly what happened here. It sounds like our global authentication is at play + some form of error on login. I don't see any exceptions in our logs, so that trail kind of dies there.

I merged your two accounts, so you should be back to one (your original) with the same Stack Exchange credential you've been using.

We'll also look into improving the "My logins" part of the profile to make it more clear what editing it will do.

Sorry 'bout the inconvenience and the confusion.

  • It happened to me once too when I tried to add Facebook login. It caused new account to be created on each site, even though I went through the proper process of "add login" etc. Dunno if it can help you debug, but just want to point that it happened before. (didn't bother to report because the bug causing me to switch providers was fixed shortly after) – ShaWiz Mar 25 '15 at 20:00
  • @ShadowWizard What do you mean by "each site"? And thanks. :) – Adam Lear Mar 25 '15 at 20:00
  • well, Stack Overflow and Meta, and think another random site not sure. Each caused a brand new account, which I didn't touch since then and not sure how to find now. :/ – ShaWiz Mar 25 '15 at 20:02
  • Thanks for your help. This network can get confusing with all these profiles, accounts, logins, e-mails, etc. That I have 2 profiles, one of which I never use anymore, is my 'fault', but it's kind of hard to get a concise overview of what's going on. – Sherlock Mar 25 '15 at 20:05
  • No repro signing in on coffee.stackexchange.com/users/552/tim I was using chrome, and signed in with FB. I normally use G+, although my SE account is linked to that. – Tim Mar 25 '15 at 21:55
1

After Anna's answer I can reconstruct what happend. I'll just post it as an answer for future reference. (I tried as a comment, but it was kind of hard to read.)

  1. Contrary to what I declared earlier, I have been on SuperUser before. I associated my old profile with that site, a few years back.
  2. I logged back into SuperUser today, only to find out that it was associated with a long-forgotten profile of mine, with personal details I don't wish to expose (anymore).
  3. I thought it was my first time on SuperUser and thought it had somehow revitalised my old profile.
  4. I panicked and deleted all my logins, thinking that would sort things. (Shouldn't have done that.)
  5. That had some results I didn't expect.

What I should have done, is just delete the unused SuperUser profile and log back in to create a new one profile with the correct profile settings (the same as I'm using on Stack Overflow now).

  • I'm surprised you were able to delete all of your credentials. Pretty sure we have something in place to prevent that... that clearly isn't working. Another thing to look into. Sorry again. – Adam Lear Mar 25 '15 at 20:07
  • No probs at all, thanks again. – Sherlock Mar 25 '15 at 20:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .