6

I was navigating this question (the circle is my finger, courtesy of Developer Options):

  1. Vertical scrolling works fine for the question and answers
  2. Horizontal scrolling works fine at first while I'm on the top of a long question / answer
  3. As I go down the amount I have to touch higher is proportional to how much is not visible from the top of the question/answer
  4. Towards the end it's really a lot, it takes a few seconds just to find the right spot :)
  5. But opening the code blocks works just fine with a tap

Demonstration of the bug

I would expect 3 and 4 to work fine as 5 hits the targeted view.


Tried Samsung Galaxy S3 @ 4.3 and Nexus 7 2012 @ 5.1.1 with 1.0.77 (those accounts are not in beta group) and it doesn't repro there.

I was able to reproduce it only on my Samsung Galaxy S4 @ 4.4.2 with 1.0.82 beta (and whatever version I had at the end of 2014). I tried disabling Developer Options to check for interference, but nothing has changed.


It may or may not help to look into setOnTouchListener -> view.getParent().requestDisallowInterceptTouchEvent(true).

I originally reported this bug via androidapp@stackexchange.com on 2014-12-06, but no response.

  • Uh, your link is dead, making it hard to see how the bug in action again... but probably it's fixed/not repro'd on latest version (1.0.77/1.0.82beta). – Meta Andrew T. Jan 26 '16 at 10:19
  • @AndrewT. created a new one. This demo is with 1.0.82 beta. Sorry about the lagging, I had to do it at 5 FPS to be able to upload it (2M limit). – TWiStErRob Jan 26 '16 at 10:35
  • Thanks, that's very clear. Unfortunately I couldn't reproduce it on Nexus 5, Android 6.0.1. Mind also providing the device model and Android version? – Meta Andrew T. Jan 26 '16 at 10:39
  • Updated question with version and repro info. – TWiStErRob Jan 26 '16 at 10:56
  • 1
    @qwer Present even today with the latest version. Can't reproduce when typing a question manually (or maybe it works when typing a question), but for longer q/a with more than 3-4 blocks it appears. I first thought it depended on the in-line code block(backticks), but now it doesn't seem so. Stock Android 4.4.2, Galaxy Note 2. – KeyWeeUsr Feb 21 '17 at 12:07

You must log in to answer this question.

Browse other questions tagged .