After successfully unsubscribing from a newsletter a message is displayed saying "Subscribed!".
This can be seen in the following screenshot: screenshot of "Subscribed!" message

I got this message on Stack Overflow but it was reproducible on multiple Stack Exchange sites.

  • 6
    Are you still subscribed too, or just an incorrect message?
    – James
    Apr 22 '15 at 0:53
  • @James It's just an incorrect message. Apr 22 '15 at 5:02
  • 1
    @James I'm not so sure anymore. If I just refresh with F5 it looks like I'm unsubscribed but if I then press ctrl+F5 (cache refresh) the newsletter option is activated again (both times after unticking "Send me the weekly newsletter" and saving settings). I also just received the email newsletter. Apr 24 '15 at 7:05
  • 1
    I can verify this. If you uncheck and save it, it only displays the "Subscribed!" button, and if you refresh the page, the checkbox is still checked. If you click to the "Manage newsletter subscriptions" link, you see that you still subscribed and you can unsubscribe only there.
    – totymedli
    Aug 12 '15 at 13:29

Unsubscribe now works as expected (uncheck the box and save).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .