7

I just logged in to SEDE with the new login thing (which was updated because Google was phasing out the old OAuth system). It seems to have not associated me with my old profile - I'm now jon.doe18288.

Additionally, when I click my profile link at the top of the screen (https://data.stackexchange.com/users/18287/jon-doe18288), I get this:

enter image description here

I don't like this. How can I associate my new OAuth login (email didn't change) with my old account, and not get errors when trying to view my profile?

15
  • works for me.... but I use google ...
    – rene
    Commented Apr 22, 2015 at 15:44
  • I got my name (not a jon.doe ID) in the top bar when I logged in, but clicking on my name to go to my profile gets the server error. Commented Apr 22, 2015 at 15:45
  • @MonicaCellio do you use a google account?
    – rene
    Commented Apr 22, 2015 at 15:48
  • @rene yes. It treated my login as if it were a first-time use of a Google account even though I've used it (in this browser) before, so I assume that was the authentication protocol switching over or something. This profile link produces the error for me. Commented Apr 22, 2015 at 15:52
  • Strange, because I had that same authentication flow and worked instantly. I'm on IE11, if that matters.
    – rene
    Commented Apr 22, 2015 at 15:54
  • Hmm. I just tried that link in Chrome (it fails in Firefox) and it's showing a brand new account -- my pre-existing data.SE account, with its bookmarked queries and edit history, is nowhere to be seen. But it used my name, not jon.doe, which is what confused me. Commented Apr 22, 2015 at 15:54
  • No repro. Using Chrome 42.0.2311.90. My SEDE account only has a google account. I can login with no issues and my existing account is untouched.
    – gunr2171
    Commented Apr 22, 2015 at 15:59
  • Fixes for the account page (which no longer has OpenIDs in some cases) are rolling out now. What was your old profile? I can fix up the logins. Commented Apr 22, 2015 at 17:17
  • @NickCraver My old profile was data.stackexchange.com/users/10904/undo, thanks!
    – Undo
    Commented Apr 22, 2015 at 17:18
  • @NickCraver my old profile was data.stackexchange.com/users/7267/monica-cellio; can you fix mine too? When I tried to log in via Google today it instead made this new one: data.stackexchange.com/users/18288/monica-cellio Commented Apr 22, 2015 at 17:24
  • @MonicaCellio try logging out and in to resolve! Commented Apr 22, 2015 at 17:27
  • @Undo fixed up - log out and in please. Commented Apr 22, 2015 at 17:28
  • Looks great, thank you @Nick!
    – Undo
    Commented Apr 22, 2015 at 17:29
  • @NickCraver fixed now -- thanks! Commented Apr 22, 2015 at 17:31
  • @NickCraver there is a report here from a user that got disassociated from the old profile as well.
    – rene
    Commented Apr 26, 2015 at 5:52

1 Answer 1

5

This was the result of bad assumptions in the profile after the OAuth changes. A fix has been deployed - and since it's open source you can just view the change here :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .