6

I'm trying to load the page for editing my profile in Stack Careers in IE11, but it locks up my browser tab. The developer toolbar's console keeps spitting out the same error:

Unable to get property 'top' of undefined or null reference.
File: stackanswers.min.js, Line: 1, Column: 4172

Here's a screenshot of the relevant bit from the minified Javascript file:

error in console

The steps to reproduce are rather simple:

  1. Go to the edit profile link, .e.g. https://careers.stackoverflow.com/cv/edit/MYIDHERE#

Some notes:

  • I've cleared my cache etc. to see if it solved anything.
  • In case I used an InPrivate session I need to log in using my Google account here. (I've tried normally and with InPrivate browsing.)
  • Result: tab keeps loading (i.e. a spinner as the tab icon, and not quite responsive).
  • This happens with and without the console open.
  • I got to mentioned link (if I remember correctly) through clicking "My Profile" top right of the page.

The page mostly loads (though the sidebar to the left is usually not loaded when the tab hangs). If I fiddle around with opening/closing the dev toolbar, and scrolling the page a bit, it sometimes loads up entirely. It then even seems to be "done loading" (the tab icon in my browser is no longer a spinner), but if I open up the console I still see Javascript errors streaming in.

Neither Firefox nor Chrome latest has this issue.

I'm running IE 11.0.9600.17631 (in Desktop mode, duh :D) on Windows 8.1 Enterprise, which is up to date.

migrated from meta.stackoverflow.com Apr 28 '15 at 14:27

This question came from our discussion, support, and feature requests site for professional and enthusiast programmers.

  • "Doctor, it hurts when I do this". "Don't do it then!". – bye Apr 28 '15 at 12:22
4

So the problem was two-fold. First some of the favicons associated with your blog posts were resolved to file:/// URIs in our database. That resulted in IE trying to go get them using the file handler. It times out after 60s and then tries to execute the rest of the script associated with the page.

Part of the remaining script goes and loads the SE answers you have associated with your profile and when it's done and there is a valid URL fragment we try to change the document body scroll offset to the anchor referenced by the fragment (which could be the anchor of one of the loaded answers).

Sadly on IE11 an empty fragment results in # being returned which we didn't catch. This is now fixed and deployed to production.

I also updated the favicon URIs to point at scheme-relative URIs instead.

Thanks for the report :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .