I'm trying to implement OpenID for my website. I wanted to look at how Stack Overflow did theirs, so I signed out. I use my WordPress account to sign in (which is what I have been using for my tests).

Unfortunately, in both cases, when I try to sign in through OpenID with WordPress, I get an error:

No openid endpoint found.

When I couldn't log in to Stack Overflow, I tried another provider on my personal site - LiveJournal - and that worked. This was working before. I do not own my own domain for my blog
- it's at http://brokenbokken.wordpress.com.

Did WordPress do something to break OpenID? Do I need to do something to my blog to make it continue to work?

  • When did you switch it to protected mode?
    – random
    Commented Oct 11, 2009 at 6:03
  • 1
    This should have been closed as 'No longer relevant', not meta.
    – Kobi
    Commented Oct 11, 2009 at 6:21
  • @Kobi Could still be useful for those who might sign in the same way.
    – random
    Commented Oct 11, 2009 at 6:29

1 Answer 1


Normally, if you're using your WordPress.com hosted blog as your OpenID, it will have these tags in the header:

<link rel='openid.server' href='http://example.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='http://example.wordpress.com/' />

But, if you ever switch your blog to protected mode and try to sign in, those two lines will not be present. As such, any attempt to sign in will fail.

Unprotect your blog, sign in with OpenID and then you can go back and return your blog back to protected mode.

  • Woot! First owned answer to a migrated question.
    – random
    Commented Oct 11, 2009 at 6:22

You must log in to answer this question.