7

As a moderator on https://raspberrypi.stackexchange.com/, I created a private chat room for the purpose of super-pinging a user to discuss some things.

After I created the room, I tried to add the user under "Enable Write Access", which says:

enter the user id or the user's profile URL

But adding the user's profile URL does not seem to do anything. It does not display "User does not exist" or any other error message, but the user is simply not added. Once I tracked down the correct ID, I was able to add the user that way.

I have since replicated this by randomly trying to add other users by profile URL -- both the base page, and the actual "Profile" link which has a ?tab=profile query string. Neither of these work, nor do they show any error.

  • 2
    Chat profile or main-site profile? – Shog9 May 9 '15 at 21:59
  • @Shog9 Main site -- I just tried the user's chat profile via the link from the actual chat and that does work. I also spend a few minutes looking around the main site profile, but I cannot find a way to get to the chat profile from there, although there is an obvious link from the chat profile to the main site one (i.e., but not vice versa). So perhaps this question should be, "How do I find a user's chat profile?" and "Feature request: Indicate what's meant is chat profile (and how to find it)". – goldilocks May 9 '15 at 23:34
  • @ShadowWizard 1) There's no such link as indicated in that pic, 2) Prepending chat. to the user's profile URL takes me to a chat profile, but it is not their's (e.g., doing this with my own URL takes me to user I've never heard of. – goldilocks May 10 '15 at 13:28
  • Of course not, you missed the fact it's a feature request only, without any status tag yet - I was just pointing you to existing request for something you asked for in a comment. (so that you won't spend time starting a new request) – Shadow The Dragon Wizard May 10 '15 at 13:39
  • @ShadowWizard All apologies. The mock-up looks so real I presumed it was something that perhaps disappeared in the last round of interface overhauls. Seems like it would be an easy enough thing to do... – goldilocks May 10 '15 at 13:42
  • 1
    lol, no problem - and as for "easy enough", those are famous last words of great many feature requests, buried in the sands of time. – Shadow The Dragon Wizard May 10 '15 at 13:44
  • 1
    @Shog9 According to my testing just now, the problem is that the URL parser doesn't believe that https://… is a valid URL. – Gilles Apr 27 '17 at 17:16
4

Replace https by http in the user's profile URL. I got hit by this one too. Apparently the URL parser wants an URL that starts with http://chat.stackexchange.com/users/ (or one of the other sites). It should allow https://… as well.

At the time of this bug https wasn't explicitly supported. Now it is so this is officially a bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .