6

I saw this question and the one it links to. My question is related but different.

At the office, I use a Google Apps account that uses Gmail. I already have a personal Stack Exchange account based on an original me@gmail.com account.

At the office, the Stack Exchange login page will not let go of the Google Apps account for login. It wants to create a new account based on that when I want to log in.

I removed Stack Exchange cookies and the cookie to stackauth.com. Then I go to login > google. It brings up the office Google information with confirm your new account. I didn't tell it "sign up", I told it "log in".

Chrome version: 42.0.2311.135

1
  • Incognito defeats the purpose. At that point I may as well just use a different browser.
    – monsto
    May 13, 2015 at 22:08

2 Answers 2

5

I've been jackin with this for a week trying not to post, and soon as I post i see a question in the 'related' bar that 1) didn't pop when I was making the post title and 2) didn't pop out of google when searching around. it didn't answer, but it gave me an idea that lead to a fix. I wouldn't have found it if I didn't make a post.

So here's how to fix it.

  1. Go to your google accounts page.
    From gmail for example: Click Name in upper right > account > Connected apps and services > Account permissions.
  2. Stack Exchange will be on this list. Click/hilite it.
  3. Right sidebar > Revoke access

NOW when you go to SE login and click google, it will ask you for google creds.

1
  • 2
    This helped me to solve the problem. However, it seems Google has updated their settings since this was posted. I found it by clicking the Google Account circle at the upper right of any Google website -> My Account -> Apps with account access (under "Sign-in & security") -> MANAGE APPS -> Stack Exchange -> REMOVE ACCESS Nov 30, 2017 at 23:20
3

They've changed it again, you have to go to any Google website -> Manage Your Google Account -> Security -> Signing in to other sites -> Stack Exchange -> REMOVE ACCESS –

1
  • 1
    Google website -> Manage Your Google Account -> Security -> Signing in with Google (under Signing in to other sites section) -> Stack Exchange -> REMOVE ACCESS Nov 13, 2019 at 16:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .