1

Markdown doesn't render the link, if the URL address contains Unicode characters such as Russian:

Тире vs. Тире

Which is:

[Тире](http://ru.wikipedia.org/wiki/Тире)
vs. [Тире](http://ru.wikipedia.org/wiki/%D0%A2%D0%B8%D1%80%D0%B5)

I never encountered this before, because I never referenced Russian (or any other language) website before, but now we have StackExchange sites in different language, such as the Russian Language one.

Can we change this Markdown setting at least for SE sites in other languages? Inability to render Unicode characters can be a nuisance, especially if people don't know how to URL encode their Unicode URLs.

2

It seems a technical issue with the RFC that is behind the definition of an URL on the web. According to this post on SO (Unicode characters in URLs), URLs can't contain Unicode characters by definition. So your unescaped Russian characters aren't valid, hence it doesn't render as URL.

Common browsers do take care of the escaping themselves, which deviates from the original URL standard. In my opinion we can't consider this a bug, but a feature request (as you did) might be in place. The SE team has to consider if they want to allow this or not.

  • The problem is that there isn't enough context to determine what codec is being used. I believe browsers track what codec the site uses, and guess until then. Stack Exchange is not going to load all those URLs and guessing isn't really an option. – Martijn Pieters May 21 '15 at 13:30
  • Besides, if you copy the URL from the browser location bar, you get a valid URL, properly escaped. – Martijn Pieters May 21 '15 at 13:31
  • That is true indeed. For both of your comments. So that would make it virtually impossible, right? – Patrick Hofman May 21 '15 at 13:32
1

Note that if using Ctrl+l (or clicking the button in the editor toolbar) to add the link, the URL gets percent-encoded.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .