3

When I try to login to "https://area51.stackexchange.com/" using my StackExchange account, I receive:

Unable to log in with your OpenID provider:

The openid.return_to parameter
(...)
does not match the actual URL
(...)
the request was made with

Steps to reproduce:

  1. Open https://area51.stackexchange.com/
  2. Click "StackExchange"
  3. Click "log in" below "Your Communities"
  4. Click "Login with StackExchange"
  5. Enter my credentials (same account as this one)

After that, I get error message. If I repeat these steps, I receive the error message one step earlier (i.e. the error is then permanent, my credentials are no longer asked for).

This issue may have been caused by an invitation to Area51 which I received earlier. That one asked me to register, and I entered my email (the same one as used by StackExchange). However, instead of connecting that one with my StackExchange account, a new account was created:

https://area51.stackexchange.com/users/136655/user136655

Maybe that account is in conflict with my existing StackExchange account?

2
  • I'm getting the same problem, but noticed that in the error message it says "The openid.return_to parameter (http : //area51.... ) does not match the actual URL (https : //area...). Could the difference between http and https be part of the problem?
    – Simon F
    Commented Jun 29, 2015 at 13:13
  • Update: Are you using Firefox with the HTTPS-Everywhere extension? Try disabling it (at least temporarily). I was able to login once it stopped trying to use HTTPS. Not ideal but maybe someone else can come up with a better solution.
    – Simon F
    Commented Jun 29, 2015 at 13:37

1 Answer 1

2

This was caused by the HTTPS-Everywhere Firefox Add-On. Thanks to Simon F for pointing this out.

It seems that area51 is not meant to be used with HTTPS, which is quite a shame!

To disable HTTPS-Everywhere just for StackExchange, you can do the following:

  • Enter about:addons in your URL bar
  • Go to HTTPS-Everywhere Preferences
  • In the list right-click on Stack Exchange (partial)
  • Select Toggle to turn it off

This is still any ugly solution, but at least you don't need to disable HTTPS-Everywhere globally.

Not the answer you're looking for? Browse other questions tagged .