2

Sometimes I get a -1 immediately after asking a question. I don't know why. Is this a bug?

I get this immediately when just 1 view is recorded that's me. No one saw my question and I have a -1!

For example I asked this question today and got -1 immediately:

I cannot compile an Android app with Qt

7

Apparently, someone didn't like your post. Maybe it was the lack of necessary information, the bad layout, etc.

Someone thought that your question was either (description from the down-vote button):

  • Not useful;
  • Not well-researched;
  • Unclear.

Since someone else up-voted you, you shouldn't be too worried. In your case, adding the error message seems to be very necessary, since the post on itself wasn't that clear. You updated your question and possibly that was the effect the down-voter was after.

| improve this answer | |
  • Thanks. Is it possible that I get a -1 automatically? – rostamiani Jun 1 '15 at 7:40
  • 5
    Not unless someone flagged your question as spam. The view count isn't updated the same time as the votes which are real-time. If you hit Refresh you will see the updated vote count. – Patrick Hofman Jun 1 '15 at 7:40
  • 1
    @Patrick not really, Even hitting refresh 10 times won't show the actual views since it's cached server side for several minutes - what we see is the actual views count up to [x] minutes ago, not sure what "x" is though. – Shadow 10 Years Wizard Jun 1 '15 at 10:02
  • 1
    @Sha that would support the general idea behind my comment even more. You can't rely on the view count. – Patrick Hofman Jun 1 '15 at 10:34
  • 2
    True, but you said " If you hit Refresh you will see the updated vote count" and this is wrong. (that's what I was referring to) – Shadow 10 Years Wizard Jun 1 '15 at 10:35
  • @Sha you are right on that. My bad. – Patrick Hofman Jun 1 '15 at 10:36

Not the answer you're looking for? Browse other questions tagged .