1

This question already has an answer here:

So in markdown the code >! makes a spoiler block.

Something like >! Hello gives

Hello

with a nice fade in/out effect. However, when you insert an image or tag like >! Hello [tag:bug] it does not display correctly. Example:

Hello this are bugs in StackExchange:

The tag does not hide itself when the mouse is on top of the block. Same for images. Example:

 >! This is a picture of Jeff Atwood: ![Jeff Atwood][1]
[1]: http://i.stack.imgur.com/3l9vY.png

Gives :

This is a picture of Jeff Atwood:
Jeff Atwood.

The text still fades in/out but the image does not. For the tag, the text fades in/out but the border does not and the text color changed from the background color of the block to green.

On older sites like GameDev, you get this.
The text "eyeballcode" is in the tilder notation thing inside a spoiler. Also, there is no fade in/out effect.

marked as duplicate by animuson Jun 5 '15 at 14:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    The image disappears on my end. It pops in and out. It's funny because they do it at different rates. The image pops in first and the text after, and then the image disappears first, followed by the text. It's like the Cheshire Cat leaving his smile behind. – Catija Jun 5 '15 at 14:24
  • I also mentioned the picture bug, which is very weird. So it is not really a dupe – Universal Electricity Jun 5 '15 at 14:27
  • 2
    But the image does disappear. For me, anyway. It doesn't fade but it's not visible. – Catija Jun 5 '15 at 14:29
  • It just goes away instantly like Poof! while the text slowly fades away – Universal Electricity Jun 5 '15 at 14:31