9

I have ran some strange thing in magento stackexchange. I tried to add a link by somelink\...\anotherlink without code quotes and strangely first forward slash went missing like : somelink...\anotherlink. So this means does stack exchange allow escape characters or is this a bug?

PS: I tried other escape characters like \n and \t but they don't behave this way.

10

No bug and yes, the backslash is the markdown escape character, allowing us to show things that otherwise won't be displayed.

For example, if you want to wrap text with underscores (and show the underscores) it will be parsed as Italics - so one way is inline code: _parsed as Italics_ however this will mark it as inline code. So another way is having: _parsed as Italics_ which is achieved by:

\_parsed as Italics_

As you see, the backslash helped the underscore "escape" the markdown.

In your case, to show the first backslash as well, just escape it with another backslash: somelink\...\anotherlink (code: somelink\\...\anotherlink)

Not the answer you're looking for? Browse other questions tagged .