I recentely tried to log-in / sign-up for Area 51 SE using my SE account (which works on crypto, infosec and sign-up here) but it showed me an OpenID related error. (See below)

I could reproduce this error across multiple days and browser refreshes and using my other OpenID provider.

Error message (shown in red, obfuscated my e-mail address):

Unable to log in with your OpenID provider:

The openid.return_to parameter (http://area51.stackexchange.com/users/authenticate/?s=bd394805-cf55-4e8e-ad73-21485a09a989&dnoa.userSuppliedIdentifier=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F642b1038-5c91-40d4-83ab-eb92db46c3d1) does not match the actual URL (https://area51.stackexchange.com/users/authenticate/?s=bd394805-cf55-4e8e-ad73-21485a09a989&dnoa.userSuppliedIdentifier=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F642b1038-5c91-40d4-83ab-eb92db46c3d1&openid.claimed_id=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F642b1038-5c91-40d4-83ab-eb92db46c3d1&openid.identity=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F642b1038-5c91-40d4-83ab-eb92db46c3d1&openid.sig=4emyzuA31ChHU0LabPGJXldbN8GeKN%2FFBJXJy69yD10%3D&openid.signed=claimed_id%2Cidentity%2Cassoc_handle%2Cop_endpoint%2Creturn_to%2Cresponse_nonce%2Cns.alias3%2Calias3.mode%2Calias3.type.alias1%2Calias3.value.alias1%2Calias3.type.alias2%2Calias3.value.alias2&openid.assoc_handle=hrQL%21IAAAAGzBtFeNGBLU2o04XSWr7ISRAbO-B2tZCK3L61IzAsuQQQAAAAEdoTN6rf9fqaP1oekJGXGXJeB8fNSVuByptp5yx1VpQbAzQwF6HJzh6a0DwedydNJ-wwpJQoN5dOLEFmndZt-L&openid.op_endpoint=https%3A%2F%2Fopenid.stackexchange.com%2Fopenid%2Fprovider&openid.return_to=http%3A%2F%2Farea51.stackexchange.com%2Fusers%2Fauthenticate%2F%3Fs%3Dbd394805-cf55-4e8e-ad73-21485a09a989%26dnoa.userSuppliedIdentifier%3Dhttps%253A%252F%252Fopenid.stackexchange.com%252Fuser%252F642b1038-5c91-40d4-83ab-eb92db46c3d1&openid.response_nonce=2015-06-12T12%3A30%3A42Z7tADDeYZ&openid.mode=id_res&openid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0&openid.ns.alias3=http%3A%2F%2Fopenid.net%2Fsrv%2Fax%2F1.0&openid.alias3.mode=fetch_response&openid.alias3.type.alias1=http%3A%2F%2Faxschema.org%2Fcontact%2Femail&openid.alias3.value.alias1=mycorrectaddress%40web.de&openid.alias3.type.alias2=http%3A%2F%2Faxschema.org%2FnamePerson&openid.alias3.value.alias2=SOJPM) the request was made with. 

As noted in the comments I'm not the only one, so I'd guess it may be not something I can fix. So will this be fixed?

Repro steps (using SE OpenID):

  1. Get an Stackexchange OpenID account (like I have)
  2. (optional?) Add other OpenID providers and check they're working (StartSSL in my case)
  3. Please note: "You" don't have an "account" for the Area 51 subpage yet and still need to do the initial sign-in.
  4. Go to the Area 51 SE page
  5. Hit "Log-in" in the top-bar
  6. Hit the "log-in using stackexchange" button
  7. Enter your e-mail and password and submit
  8. Get the above error

Repro steps (using other OpenID)

  1. Perform as above (until step 4), but this time step 2 is mandatory
  2. Hit "more OpenID options"
  3. Provide your OpenID link XXX.provider.com (works on crypto, server fault, ...)
  4. Authenticate against your provider
  5. Receive a variation of the above error (can be included if needed)
  • Whoa, that second URL doesn't look right...Can you describe the exact steps you're taking to log in? It looks like you're using a Stack Exchange OpenID, but I'm unable to reproduce this either by using the "Log in with Stack Exchange" button or by manually pasting the OpenID URL in the box under "more OpenID options".
    – Adam Lear StaffMod
    Commented Jun 12, 2015 at 18:28
  • @AnnaLear, I've added the repro (as far as I can tell).
    – SEJPM
    Commented Jun 12, 2015 at 18:36
  • Hmm. I can't reproduce this at all. Fun.
    – Adam Lear StaffMod
    Commented Jun 12, 2015 at 19:18
  • 1
    FWIW, I have exactly the same problem. I have no issue using SE OpenID on various SE sites, but so far only Area51. For bookkeeping, I just went to Area51 from the top-left drop-down menu. Hit the "Log In" link. Select SE OpenID, enter same mail and password as other SE sites, and gets the same error message as SOJPM. Is the log-in procedure on Area 51 different than other sites (the interface does look different)? Commented Jun 16, 2015 at 6:17
  • 1
    @bilbo_pingouin It's not really different, but the UI was never updated after the last redesign. It should work the same. Clearly it doesn't in some cases. I'll look further.
    – Adam Lear StaffMod
    Commented Jun 16, 2015 at 23:15
  • @AdamLear & others: related/same: meta.stackexchange.com/questions/276702/… ?
    – lofidevops
    Commented Mar 15, 2016 at 13:51

1 Answer 1


If you're running any browser extensions like HTTPS Everywhere, turn them off. Area 51 login doesn't support that sort of forcing of HTTPS.

(SSL support is on our list and work continues to make it a reality as we have time. Once it's fully supported, this issue should be resolved.)

  • Deactivating HTTPS Everywhere does indeed work around the issue :)
    – SEJPM
    Commented Jun 10, 2016 at 13:18
  • @Adam can you merge this one with this other similar report? Both got good answers so I'm not sure if it's good idea to just close as duplicate as answers will be lost. (for anonymous visitors who are redirected.) Commented Aug 21, 2016 at 4:06
  • @ShadowWizard Meh, this answer doesn't add all that much. I'm okay with the other post being the canonical one, as it were.
    – Adam Lear StaffMod
    Commented Aug 21, 2016 at 4:11
  • Thanks, I just voted to close this one as dupe of this, so now it looks pretty weird (closed as dupe of two, where one is dupe of the other). Meh indeed though. :) Commented Aug 21, 2016 at 4:14

Not the answer you're looking for? Browse other questions tagged .