4

When I tap the favorite star in the android app for a question I asked, the question is not favorited. Instead a red banner appears at the top that says "Question not favorited." Is this a known bug?

I'm running version 1.0.6 of the app

UPDATE: Alternatively, when favoriting a question I did not ask, I get the following message

The account associated with the access_token does not have a user on the site

The above message occurs with version 1.0.73 of the app.

6
  • Are you logged in on the site you wanted to favorite the question? Try doing an action that will make you logged in first (e.g. add comment, vote)? Oct 30 '15 at 4:44
  • I deliberately logged out, then in, before favoriting. Does that count? Oct 30 '15 at 11:28
  • That... Should fix the issue... Because I can't repro this on v1.0.73 (I'd say device is irrelevant since it's about API call) Oct 30 '15 at 11:34
  • I log in using my Google account, if that helps. Also favoriting on the site, within the mobile Chrome browser, works. Oct 30 '15 at 12:56
  • After a) re-flashing my device several times due to an unrelated issue, b) rooting said device and c) logging back into the app (using my Google login) I was able to favorite a question. I'm not adding this process as an answer for obvious reasons, however I am running version 1.0.75 of the app...which may be the fix Nov 27 '15 at 23:25
  • OTOH, this exakt same behavior appeared in Version 1.0.85 on Android 5.0.2 .
    – guntbert
    Apr 20 '16 at 19:10

You must log in to answer this question.

Browse other questions tagged .