3

When trying to upload a picture from my phone, the Android app crashes a few different ways, depending on whether I select the Gallery or Photos image source. (Uploading by manually entering a URL works perfectly.) The problem occurred using beta versions 1.0.63, 1.0.71, 1.0.72, and now 1.0.73, on a Samsung Galaxy S4 running Android 4.1.2.

These are the steps which I've used:

  1. Open an Ask/Answer a Question window, enter a sentence.
  2. Click on the picture icon, which opens a "Choose Image Source" window.
  3. Select "From Device," which opens a window offering a choice of "Gallery" or "Photos."

If I select Gallery, when the pictures open, choosing one causes the app to immediately crash. The circle goes around for about 15 seconds (see picture on left below), then re-opens to the Ask a Question window, where the original text is still visible. The camera icon isn't live (it's grayed-out), so trying to post again in that window is not an option.

If I select Photos, when the pictures open, I can choose one. It pauses, which I interpret as an effort to post. After about 10 seconds, however, the app crashes to the feed screen, and an error message in a black box appears which says "Unfortunately, the process com.stackexchange.marvin has stopped." (See picture on right below.) There are Report and OK options under the error message. Initially I was able to get a screenshot, however the message disappeared before I could select Report, then the app crashed. However, on 8/11/15, and a few times since, I've been able to submit a report before the crash.

Update 9/2/15: With version 1.0.72, the error message varied, and many tries produced a picture a few times. There was no indication as to when or why it would happen, and each of those times, the picture posted sideways. With version 1.0.73, the error message has returned to the original, and fifty tries have not produced a posted picture from either Gallery or Photos. I'm updating this report in the hope that others are experiencing the same problem, or to be notified if the developers are aware of it. Thanks!

Stuck Screen Bug report screen

  • The linked bug report is about the iOS app so not really relevant. Anyway since the whole image upload in the android app is pretty new (about one month) you're the first to report this bug. – ShaWiz Jun 16 '15 at 19:47
  • I couldn't repro this on Android 5.1.1, app 1.0.72 beta. Perhaps it has been fixed, or it's device/Android OS dependent. Could you update the status if you're still using that version? – Meta Andrew T. Aug 11 '15 at 6:07
  • @AndrewT. I hadn't tried to post a picture since reporting this issue. What happens now is that the picture attempts to load, as in my screenshot on the left, but then returns to the Ask Question box. I have my phone set to update automatically, but the version I have is 1.0.71, which matches the version in the Play Store. Is 1.0.72 a limited, or device specific, roll-out? – Sue Aug 11 '15 at 14:44
  • I see, then I assumed the app still crashes when trying to upload the image. Did this happen on both image picker apps (Gallery and Photos)? Btw, The 1.0.72 is currently in beta, you can enroll into beta tier if you want. – Meta Andrew T. Aug 11 '15 at 16:15
  • It happens in both image pickers. I tried numerous times again, to no avail. I provided extra detail to the section about posting from the Gallery. Also, I was able to send a report directly through the phone today. I can wait to enroll in the new tier if you think it would be helpful to others for me to keep using this version while the bug is being researched. – Sue Aug 12 '15 at 0:21
  • @AndrewT. I downloaded Beta 1.0.72 and upgraded Photos to version 1.3.0.101074912. I'm having the same, and new, problems! I'm stubborn, so I've tried everything I could think of 50 times! Once from Gallery and 3 times from Photos, it has loaded a photo-sideways! It then grays out the camera, so I can't add another! This is only important to me if it helps others, and there's been no new attention here. The app has crashed so many times, the devs must have seen the reports, so I'm fine letting this be, unless you think I should edit the post. Thanks! :) – Sue Aug 25 '15 at 21:35
1

I just tried to reproduce and after about 10 seconds of waiting, error showed up about invalid or missing access token - it went away before I had the chance to take a screenshot. However, app didn't crash. Hope it would help the dev team debug and fix it.

  • Thanks for checking into this, and for editing my question. I tried some additional things to make this a more complete report, including pictures. It appears that my error message was different than yours! – Sue Jun 17 '15 at 3:28
  • @Sue yep probably different android version or device. – ShaWiz Jun 17 '15 at 4:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .