5

On the team page, some of the last employees profile links which look like https://meta.stackexchange.com/accounts/{user-id} (i.e. https://meta.stackexchange.com/accounts/6110016) are borked.

The correct format is http://stackexchange.com/users/{user-id} (i.e. http://stackexchange.com/users/6110016).

  • OMG another legit whinge? I think I heard the 4 horsemen of the pixelated apocalypse! – user289879 Jun 17 '15 at 6:54
7

I update this page manually, and the tool I use to look up employee's user accounts lands me on the site that formats them the wrong way: meta.stackexchange.com/accounts/{user-id}

Usually I do a couple of clicks to take me to their network profile, but last week I was updating the page with a lot of new employees and got lazy/ didn't realize users couldn't even see the page I was looking at so I was just putting in the wrong link.

So I don't know if it's still a bug if it's human error, but it should be fixed now. Thanks for the report!

  • Of course, I don't trust you being an employee, unless you get, you know, the jewellery. :p – nicael Jun 16 '15 at 22:19
  • 1
    Oh, I don't know what would happen if I were trusted with a diamond! Probably system failure. – cashnwho Jun 16 '15 at 22:21
  • And you just pretend that's not you who caused that failure... :D – nicael Jun 16 '15 at 22:24
3

I agree this is a bug small oversight . I found the links you were talking about and can confirm that following them is erroneous.

I used this method:

$('.employee').filter(function(){
 return this.href && this.href.indexOf("account") > -1;
}).toArray().map(function(el){ 
 return $(el).find('.employee-photo')[0].alt    
});

Which yielded the five candidates who need links fixed

["Brantley Pace", "Katy Ostermeyer", "Alex Davis", "David Barocas", "Mandy Manke"]

It occurs all in the same area of the page.

enter image description here

  • And, to be serious, why to post this kind of "confirmation" answer? ;) eh, have an upvote anyway, what to do... – nicael Jun 16 '15 at 21:40
  • @nicael - It was posted to add to the rigor of your claim :) This is easily reproducible, easy to see with an image instead of manually inspecting the claim, shows the entirety of the set of links affected, and has both jquery and a hand drawn red circle. – Travis J Jun 16 '15 at 21:48
  • 1
    @TravisJ Thanks for the confirmation, but I gotta say... you spent way too much time on something that's pretty obviously broken/easy to reproduce. :) – Adam Lear Jun 16 '15 at 21:50
  • @AnnaLear - It only took about 3 minutes to mock this up (I really like the paste image into upload feature). I think I spent more time responding to comments :P Also, from the first version of the question it was not obvious which parts were exactly broken and I felt this narrowed the scope. – Travis J Jun 16 '15 at 21:51
  • First version... What? You mean in the first 15 secs you started preparing an answer?.. – nicael Jun 16 '15 at 21:53
  • @TravisJ I didn't say "a long time", I said "too much". ;) (And now I'm perpetuating the problem. :D) – Adam Lear Jun 16 '15 at 21:53
  • @nicael - Clearly misspoke there. It should read "from the question" and not first version. When I first read your question I still had to go to the SE team page and then manually figure out if any or how many of the links were broken on my own. If you had included this information in your post I would have just upvoted and moved on instead of posting it here in an answer. – Travis J Jun 16 '15 at 21:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .