11

I tend to browse Stack Exchange equally on PC and tablet.

I've noticed for some time that the icon shown in the hot network questions for questions on the Skeptics site is different dependent on the browser used.

Safari, Ipad

Chrome, Windows

Is there any reason for this inconsistency or is it simply a bug?

  • The original (you must zoom to actually see something) is black so it means the Safari and/or iPad are doing some trick over it. – Shadow The Dragon Wizard Jun 28 '15 at 14:25
  • @ShadowWizard - Except maybe if it serves up a different sprite image for the ipad and for some reason the styles aren't consistent between the two? – Martin Smith Jun 28 '15 at 14:28
  • hmm... excellent point! But since you appear to use the full site theme (mobile theme doesn't have that list) I doubt it. Can you somehow check? – Shadow The Dragon Wizard Jun 28 '15 at 14:34
8

This depends on the screen resolution. The one with the white background is loaded when the screen resolution is high; the one with the black background is for low-dpi displays. I've checked on the multiple devices. Appears that any icon has its "retina" alternative.

The low-res icon set: http://sstatic.net/img/favicons-sprite16.png

The high-res icon set: http://sstatic.net/img/favicons-sprite32.png

(The black background on the low-res is possibly related to the resizing bug which converts transparent background into the black one; this bug was already reported)

  • OK - So is it deliberate that the high res and low res icons be visually so different? I don't see this kind of jarring discrepancy for any other site. – Martin Smith Jun 28 '15 at 14:32
  • @Martin It's related to the resizing bug which applies black to the transparent background. – nicael Jun 28 '15 at 14:34
  • ha! I actually knew that and forgot. – Shadow The Dragon Wizard Jun 28 '15 at 14:35
  • @nicael - I'm not familiar with that one, is this a bug in Chrome? Or the image processing? – Martin Smith Jun 28 '15 at 14:37
  • 1
    @Martin Bug in SE image processing, reported already :) – nicael Jun 28 '15 at 14:38
  • 1
    Actually, they do have transparent version. see this bug report. – Shadow The Dragon Wizard Jun 28 '15 at 14:38
  • @Sha But this is the same medium version, i.e. sprite32.png, no? – nicael Jun 28 '15 at 14:40
  • didn't check, anyway it's not related to the resize losing transparency bug, since it's not hosted on imgur at all. – Shadow The Dragon Wizard Jun 28 '15 at 14:41
  • It isn't answered until "Is there any reason for this inconsistency or is it simply a bug?" is answered. And only a dev can answer that I would have thought. – Martin Smith Jun 28 '15 at 19:37
  • @Matrin Got it, fine. – nicael Jun 28 '15 at 19:37
  • @nicael - I'm sure you won't have to wait too long for the +30 to tip you over 10K if that was the motivation for asking... – Martin Smith Jun 28 '15 at 19:47
  • @Martin Lol, I will have to wait till tomorrow, coz I've rep capped :) MSE needs some more new questions :D – nicael Jun 28 '15 at 19:48
  • @nicael I know, I upvoted 3 of your answers recently (inc this one) when you were on 9970 and thought I'd pushed you to get mod tools. When your rep didn't change, I saw in your profile you had been capped :( but, you seem to have hacked that. So congrats :D (something was reversed somewhere I presume) – James Jun 28 '15 at 21:31
  • 1
    @James No hack! I've got another accept and accepted a few answers myself :) – nicael Jun 28 '15 at 21:33
  • Nice. (I was joking, but you never know, you might have found a bug in the rep cap system :D) Nearly there myself - Is it... is it... everything you hoped it to be? :D – James Jun 28 '15 at 21:35
3

This issue now appears to be resolved.

The new Skeptics icon displays consistently on Ipad and desktop.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .