6

UPDATE: As of today (Aug. 13, 2015) I can confirm real-time tab is working flawlessly! I can see the expected behavior and everything is working as it should. I don't know when this was fixed but thank you for fixing this!


I just noticed an interesting thing on the Stack Exchange real-time tab posts display. The very first-time when the listing gets loaded, it correctly shows the time in secs giving you the real-time feel. You get very little time to notice this (you can always hit the "reload" button) change. But as soon as the next question is loaded in the list, all of the posts are displayed with "active 5 mins go". If you scroll down further, the little older posts will show "active 6 mins go", etc.

Why does the real-time gets replaced with static value after the initial load? Why not leave the time as it is? Or, does this belong to category? Can anyone please explain.

Does not work: (Mac OS)

I tried it on three different browsers (after removing cache and history) on my MacBook Pro (OS X Yosemite Ver. 10.10.2) and all of them had the same problem i.e. worked perfectly on the initial load but later when the new question came in, all of the posts got active 5 or 6 mins. ago status. Please see the first three screenshots below for the Mac OS browser's output.

Works perfectly (from just now to secs. to mins.) on Windows 8.1 OS with Internet Explorer 11. (see the 4th screenshot below)

** Right-click on screenshots below and open image in new tab to see the full version.

Chrome Incognito window Screenshot: (Version. 43.0.2357.134 (64-bit))

enter image description here

Firefox Screenshot: (Version 39.0)

enter image description here

Safari Screenshot: (Version 8.0.7 (10600.7.12))

enter image description here

Internet Explorer Screenshot: (Version 11.0.9600.17905)

enter image description here

  • No-repro on Iceweasel 31.8. The first load shows "X secs" or "just now". When the auto loading of a new post is activated, the post time of the previous posts (under the new one) are advanced a few seconds, this happens every time a new posts is auto added to the list. Even if I let loads of new posts be auto added, scrolling to the bottom one is only posted "1 min ago" – James Jul 21 '15 at 12:18
  • @James I am using Google Chrome. Just tried Firefox and Safari and its shows "active 5 mins ago" ... – HackerKarma Jul 21 '15 at 12:23
  • @James nope... same result even after clearing cache in all of them... Do you have Chrome or FF? – HackerKarma Jul 21 '15 at 12:31
  • 2
    Iceweasel is a fork of Firefox (I'm on Debian). I won't install Chrome though (sorry) IMO it's buggy/crappy/prone to security issues. Someone else with those browsers will report soon. Might be worth editing your question and adding the exact browser versions you repro with. – James Jul 21 '15 at 12:34
  • 1
    Working fine for me on Chrome Version 43.0.2357.134 (64-bit) FF 39.0 for OSX. – Catija Jul 21 '15 at 14:44
  • Added screenshots for the reference – HackerKarma Jul 21 '15 at 15:34
  • Please add a [status-completed] tag to this question as it's been fixed! – HackerKarma Aug 13 '15 at 18:35

You must log in to answer this question.

Browse other questions tagged .