7

Currently, when I flag a question with either "duplicate" or "should be closed" (I haven't tried the other (exception spam) flags yet), I get the enter image description here as a status for the marked post in my "flag summary" section. But, when I mark the post with a "spam" flag it does not show any status like "pending".

Here is a screenshot of one of the post I flagged it as a "Spam":

enter image description here

I would like to know if the spam flag has a "pending" status or not. Is there a timeframe that one has to wait before the "pending" status gets to applied to? As in this case I only waited for a minute or so. But for other flags that I have tried it was almost instantaneous. Or, does this belongs to category?

2
  • 4
    Now, the golden question: Should I flag this as spam to repro? ;)
    – M.A.R.
    Jul 31 '15 at 16:10
  • @inɒzɘmɒЯ.A.M haha... good one... my thing is should I call this a "bug" or a "feature-request". I would to see what SE team has to say here so that I can add a correct tag to this post Jul 31 '15 at 16:13
11
+50

I am a moderator on another site.

Yes, this is just part of the UI. As long as you don't see "helpful" or a "declined" message, the flag is in the moderator queue. Unless a moderator happens to find a reason to handle the flag manually, it will stay up until the post gets deleted.

Also, there is no timeframe for this and the UI will stay the same. However, spam/offensive flags will expire after 48 hours if the threshold (6 community flags or 1 moderator flag) isn't reached. If this happens, that flag may or may be removed from your flagging history. Either way, it will not count against you.

3
  • +1 and thank you for your findings. So when you say "this is just part of the UI" would that indirectly means [status-bydesign]? Also, if "the flag is in the moderator queue" then shouldn't it say "pending"? Now, I am confused what would be the correct tag for my post. Should I call this a "bug" (it's not if it falls under [status-bydesign] category) or a "feature-request"? Jul 31 '15 at 16:20
  • 2
    @HackerKarma: I'm guessing there is a reason for this, but I don't know. An employee may need to explain further.
    – Jamal
    Jul 31 '15 at 16:30
  • As per this post - Spam and offensive flags expire after 48 hours if the thresholds aren't reached. May be you can modify update your post statement i.e. "spam/offensive flags can expire if they're not handled after a certain time". Aug 21 '15 at 15:25
7

Spam flags are pending until they are marked helpful or declined. The UI doesn't show 'pending' on pending spam flags unlike other flags. This is just the UI—the flag is pending and will be handled as usual.

3
  • +1 for the finding. So, indirectly you are saying that it's a [status-bydesign] I will wait for a day or two and see what moderators / high-reps. have to say before I can accept your answer. Jul 31 '15 at 14:29
  • @HackerKarma I'm not sure if it's a bug but it's been this way for a while now. I seem to remember it showing 'pending' on all types of flags a long time ago, but was changed (or I'm mistaken).
    – grg
    Jul 31 '15 at 14:30
  • Let's wait and see. Also, I can't even reproduce this "spam" flag as for that you need a spam post first. Then, I can wait on it and see if there is any time limit set for the "pending" flag to appear especially for the "Spam" flag. Jul 31 '15 at 14:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .