22

After the move of all services to Denver it was tweeted that there was some performance degradation. Initial reports showed that at least chat search seemded to be the victim of that.

I would like to add Stacksnippets to that list of reduced functionality.

<h1>help!</h1>

If this is intended due to less resources available I'm Ok with that, I'll switch back to jsfiddle.

If this is an oversight, can you give that server some love?

  • Love won't be enough for the poor server, it needs some juice! Lots of electrons to run through its veins. – Shadow 10 Years Wizard Aug 9 '15 at 9:25
  • Love is almost free @ShadowWizard ... – rene Aug 9 '15 at 9:26
  • Not anymore, we're long time after the 60's... – Shadow 10 Years Wizard Aug 9 '15 at 9:28
  • Please, don't take me down memory lane – rene Aug 9 '15 at 9:29
  • 2
    hey are you sock of @Bart?! Only he is old enough to actually be in the 60's and remember it.... :-D – Shadow 10 Years Wizard Aug 9 '15 at 9:31
  • 1
    I don't know but I asked him... – rene Aug 9 '15 at 9:34
  • Related: Searching on chat always returns no results. – tchrist Aug 9 '15 at 13:21
13

That's a bug. We'll investigate.

Update: I see the problem. Working on it

Update: Fixed. Thank @nick-craver for doing the heavy lifting!

| improve this answer | |
  • 1
    Just curious: don't you have alerts in place when major feature like that just stop working and/or whole service is offline? (i.e. you need to wait until someone spot this and report?) – Shadow 10 Years Wizard Aug 9 '15 at 17:21
  • 1
    In general, yes. This service is missing alerts. I've filed bugs to have them created. Why that part of our launch checklist was skipped is something else we'll be investigating. – Tom Limoncelli Aug 9 '15 at 17:24
  • OK, fair enough. Thanks! – Shadow 10 Years Wizard Aug 9 '15 at 17:25
  • Thanks for sharing the love ... send some to Nick as well ... ;) – rene Aug 9 '15 at 17:30
  • Glad to help! Thank you for bringing this to our attention. Next step: an alert that tells us if we are missing an alert! :) – Tom Limoncelli Aug 9 '15 at 17:32
  • Don't don't do the alert for missing alerts thing... This is the only thing that a process is good for. That or additional checks. – ben is uǝq backwards Aug 9 '15 at 18:49
  • Nope, still not working... – AStopher Aug 9 '15 at 20:31
4

Was going to write this as a comment, but I thought I'd make it a full-blown answer instead...

The issue still exists, but however it just seems to be a matter of the server certificate rather than the actual server availability itself:

enter image description here

when loading the Snippet as a full-page frame:

enter image description here

After clicking 'Advanced' and clicking 'Proceed', I can go back to the Snippet and see it perfectly. On Chrome 44.0.2403.130 (Official Build) m (32-bit), Windows 10 Pro x64. System clock is synced, so it's almost certainly server-side.

Edit As discussed in the Tavern, it turns out that quite simply, the incorrect SSL certificate is installed on stacksnippets.net. An issue which is easily fixed.

| improve this answer | |
  • https is not supported, unless this worked before then it is a regression. – rene Aug 9 '15 at 20:42
  • @rene I haven't ever used a plugin to force HTTPS (such as HTTPS-Everywhere) and I've also cleared my cache. Seems to be Stack Exchange forcing the HTTPS, not my browser. Saying that, I just tried it on Edge and it worked perfectly fine first-time. – AStopher Aug 9 '15 at 20:45
  • But in your dev console I see calls to https.... nobody is forcing you to ssl, you seem to be already there... – rene Aug 9 '15 at 20:52
  • @rene AdblockPlus doesn't try to force HTTPS, does it? that's the only thing I can think of... – AStopher Aug 9 '15 at 20:59
  • @rene right after first login, user arrives to the https version of the site. And as you see here, in such case snippets are still borked. Not sure whether it worked before or not though. – Shadow 10 Years Wizard Aug 9 '15 at 20:59
  • 2
    @cybermonkey anyway, this better be posted as new bug, tagged with ssl as well. – Shadow 10 Years Wizard Aug 9 '15 at 21:01
  • sure, ssl is not supported, Nick didn't bring the certificate with him from NY and now we are discussing a bug in a functionality (namely SSL) that isn't supported anyway... ;) – rene Aug 9 '15 at 21:02
  • @rene but we love to give the team some future work, don't we? ;) – Shadow 10 Years Wizard Aug 9 '15 at 21:02
  • Yep, we do... we keep those bugs coming... – rene Aug 9 '15 at 21:03
  • @ShadowWizard meta.stackexchange.com/questions/263383/… – AStopher Aug 9 '15 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .