When I receive a message on an SE post, I get a notification like this:

App Notification

If I double tap this notification, the SE application opens, but my feed is empty approximately half the time. It looks like this:

Empty Feed

If I refresh the feed (slide from the top), the feed does refresh and shows the new notification.

The notification, above, leads to this comment.

I haven't figured out the pattern yet, but this occurs roughly half the time I open a notification. It's occurred for chat messages, comments and answers - but not consistently. I have received notifications for the same post (for example, the two comments after the one linked above) that do not show an empty feed. But, a chat message barely 10 minutes later will show the empty feed again.

I am utilizing the beta app - version 1.0.72 on Android 5.0.1.

  • 3
    Repro'd on Nexus 5, Android 5.1.1, and IIRC since 1.0.69 or 1.0.70 (also on beta). Commented Aug 11, 2015 at 4:39
  • 1
    Repro'd on Samsung S4, Android 5.0.1 on 1.0.71, but also sporadically on earlier versions Commented Aug 11, 2015 at 6:22
  • 4
    possible duplicate of Clicking notification from lock screen shows app with blank message drawer Commented Aug 11, 2015 at 7:07
  • 1
    Repro'd on OnePlus One, android 5.1.1 and 5.0.1, cyanogen 12.1
    – Tim
    Commented Sep 7, 2015 at 14:10
  • reproducible on android 4.4.4 with app version 1.0.73. I wonder why this issue is still not fixed even though it was reported in version 1.0.70 Commented Sep 15, 2015 at 6:08
  • @dreamweiver some bugs take long years until a dev even see them, this one is probably not different. Commented Sep 15, 2015 at 6:13
  • As a developer I personally feel this is not a big issue .if someone hire me into SO , I can look into it ;) Commented Sep 15, 2015 at 6:34
  • 3
    This is annoying... looking into it, it's not something I've been able to see using the app internally yet. Commented Sep 21, 2015 at 15:12
  • 1
    Repro'd on Samsung S3, Android 4.4.2 with version 1.0.73 and all prior versions since I installed the app a few months ago. Happens 100% of the time on current version for me. Commented Oct 9, 2015 at 19:02
  • @Kasra any update when the fix will be pushed? Commented Oct 12, 2015 at 18:02

1 Answer 1


sorry about the long delay, this is finally fixed.

I had to go deep into the rabbit hole before I found a simple fix, basically what was happening is that our notifications have a flag that tells the app if it should force a reload of the inbox or not when being viewed, this entered a weird edge case when the app was doing a cold boot so it didn't have any previous notifications cached, so it tried to jam the new one into that list instead of refreshing the entire list but since it was an empty list... well you saw what happens.

This is going to be fixed in version 1.0.74+, coming out in the next 48 hours (as soon as I figure out why my builds don't build anymore)

  • @ShadowWizard I DID IT Commented Nov 10, 2015 at 19:20
  • Now it's even worse - it does not go to the inbox at all, just to the last open page. :/ Commented Nov 20, 2015 at 14:31
  • Update: it happens only if the app was running in background. If I remove it from memory (e.g. Clear All in LG) then tap a notification, it's working fine. Commented Nov 20, 2015 at 14:53
  • @ShadowWizard have you been able to repro this? I haven't :( Commented Nov 24, 2015 at 0:21
  • Yes happened just now with this very notification. I suspect it happens only when I have a single notification, when there are more than one it works. Commented Nov 24, 2015 at 4:42
  • @ShadowWizard what device and OS version are you using? Every time I leave the app running in the background and enter from a single push notification the inbox opens for me. Commented Nov 24, 2015 at 19:27
  • LG G3, android 5.0 Commented Nov 24, 2015 at 19:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .