23

There is a question on the Ru.SO that can't be opened (at least for me under Chrome and Edge) with HTTP 400 error:

I have made a dumb question on Meta.SE to reproduce this.

Question

Bad Request - Invalid URL

HTTP Error 400. The request URL is invalid.

In case of edit, direct URL can be used.

I believe it's because a "�" character in the URL of the question and the cyrillics. Only appear if the title contain both cyrillics and this character.

  • 6
    huh! reproduced on MSE – Shadow Aug 22 '15 at 15:03
  • @ShadowWizard Actually, it was me. :D I just edited an original question, so it can be actually answered. – m0nhawk Aug 22 '15 at 15:06
  • Oddly enough, the link works fine on the mobile app. – Ixrec Aug 22 '15 at 15:24
  • 7
    @lxrec And why it shouldn't? I bet the mobile app didn't use the title as an URL and just request the title and body by API. – m0nhawk Aug 22 '15 at 15:26
  • 1
    Looks like some sort of block in the IIS level to me – Shadow Aug 22 '15 at 15:50
  • The direct link to: meta.stackexchange.com/q/264085 doesn't work either. – durron597 Aug 22 '15 at 15:57
  • 2
    I wonder who managed to vote on it and where the views came from – Lix Aug 22 '15 at 16:07
  • "с кириллицей" == "with cyrillic" on Russian – user259412 Aug 22 '15 at 16:14
  • 2
    @Lix it seems Ixrec could access it on their mobile... so probably him/her... – ᔕᖺᘎᕊ Aug 22 '15 at 16:46
  • 1
    Too much high tech stuff... I'm getting dizzy – Anthony Pham Aug 22 '15 at 16:51
  • @Lix maybe someone used the API to upvote it – Universal Electricity Aug 22 '15 at 17:23
  • @durron597 because it cause a 301 header then redirect to the bad URL. – Shadow Aug 22 '15 at 17:47
  • @ShadowWizard half answer: It's definitely not because of "�" character as I can open another post – HackerKarma Aug 23 '15 at 14:28
  • 1
    @Hack really better let the team handle this, and hopefully write a post-mortem report when it's all over. – Shadow Aug 23 '15 at 20:08
  • 1
    @HackerKarma it isn't really the encoding as such; IIS (or something else in our stack) just seems to hate that codepoint - it isn't isolated. – Marc Gravell Aug 24 '15 at 14:44
-3

Not 100% unviewable:

Use the API:

http://api.stackexchange.com/2.2/questions/264085?order=desc&sort=activity&site=meta&filter=!0Uv6ZT)nwkwHYT3ON9gGlQ3gB
{
  "items": [
    {
      "tags": [
        "bug",
        "hyperlinks"
      ],
      "owner": {
        "reputation": 442,
        "user_id": 186774,
        "user_type": "registered",
        "profile_image": "https://www.gravatar.com/avatar/d28147f1a035b2ddfc943edc98cd5e0f?s=128&d=identicon&r=PG&f=1",
        "display_name": "m0nhawk",
        "link": "http://meta.stackexchange.com/users/186774/m0nhawk"
      },
      "comment_count": 0,
      "close_vote_count": 0,
      "is_answered": false,
      "view_count": 3,
      "favorite_count": 0,
      "down_vote_count": 0,
      "up_vote_count": 3,
      "answer_count": 0,
      "score": 3,
      "last_activity_date": 1440260151,
      "creation_date": 1440255100,
      "last_edit_date": 1440260151,
      "question_id": 264085,
      "link": "http://meta.stackexchange.com/questions/264085/%ef%bf%bd-cause-a-problem-on-opening-question-with-cyrillics-%d1%81-%d0%ba%d0%b8%d1%80%d0%b8%d0%bb%d0%bb%d0%b8%d1%86%d0%b5%d0%b9",
      "title": "«�» cause a problem on opening question with cyrillics (с кириллицей)",
      "body": "<p>� sign cause a problem on accessing the question.</p>\n\n<blockquote>\n  <p>Bad Request - Invalid URL</p>\n  \n  <p>HTTP Error 400. The request URL is invalid.</p>\n</blockquote>\n"
    }
  ],
  "has_more": false,
  "quota_max": 10000,
  "quota_remaining": 9972
}

Or just plop it into the sandbox:

http://chat.meta.stackexchange.com/transcript/message/3867804#3867804

enter image description here

  • Uni what is this API output? You can get the same error under dev tools 'Network' status – HackerKarma Aug 22 '15 at 18:14
  • @Hack what do you mean? But I just edited the answer, so is that what you're talking about? – Universal Electricity Aug 22 '15 at 18:17
  • I mean to say ur JSON output HTTP error code 400 Invalid URL – HackerKarma Aug 22 '15 at 19:04
  • Uni, You're giving example of API call which returns the JSON data that one can parse and render which is working on mobile app already. Whereas, Meta.SE is making a HTTP (and not API call) request here. – HackerKarma Aug 22 '15 at 21:34
  • 9
    I don't see what purpose this answer serves. Yes, Stack Exchange API exists and is well documented. This has nothing to do with HTTP request failure. – user259867 Aug 22 '15 at 22:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .