12

� sign cause a problem on accessing the question.

Bad Request - Invalid URL

HTTP Error 400. The request URL is invalid.

  • 1
    This question opens in the mobile android app, but not on the mobile theme in a browser – Andy Aug 22 '15 at 18:02
  • 7
    Yep, it sure does. Please don't put that back into the title while I fix it! I've edited at the database level to make this question available. – Marc Gravell Aug 24 '15 at 14:17
  • A way to test if this is fixed is following this link – Braiam Aug 24 '15 at 15:05
  • 5
    @Braiam no, it isn't; the fundamental problem is outside of our part of the stack: we can't make IIS happier. What we can do, however, is to not generate links that won't work. Which is what is now the case. And in particular: to not force a redirect to a broken url. Hence why you can now view this question. – Marc Gravell Aug 24 '15 at 15:07
  • @Andy: I wondered how the question had five votes when my best URL hacking couldn't get it to display.... – Nathan Tuggy Aug 24 '15 at 19:05
  • @MarcGravell then, why other web servers allow such combination? AFAIK, RFC 3986 allows any unreserved character using the percent-encoding method. – Braiam Aug 24 '15 at 22:15
  • @Braiam because software often has glitches in a few edge cases – Marc Gravell Aug 24 '15 at 22:44
11

There are some Unicode combinations that IIS just hates and refuses to play with no matter how much you %-encode them. You seem to have found another one! Congrats.

This will be fixed in the next build.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .