8

Disclaimer: I'm writing this from my phone, so a lot of words may be misspelt, or changed due to auto-correct. I've got a cast on my wrist so that will definitely help too. Also, I'm not very happy, I've spent an hour figuring out a way just to post this. If you're looking for the real fun, and don't care about context, skip the first three paragraphs.

I've encountered a very, strange, persistent bug. I had been checking my Urban Planning Proposal in light of the strange events surrounding disappearances. I also went there so that I could figure out how to follow it being an unregistered user, and then describe the steps to interested people who have never heard of SE before. So I logged out, and cleared my website data as well, since I needed to clear it anyway.

So, off I went, and I followed my proposal, and it asked me to verify my email address. I entered my secondary email (my primary is for my main account, Zizouz212). I went, verified it, and added this "user" to the following list. I unfollowed, and for some reason, tried it again. It asked me to enter my email again, and verify it, again. So I did. And then I proceeded to getting rid of this "user." That was impossible: there was no delete option available in the profile page, both on main, and Area 51 discussions. But, I logged out.

I figured I'd go back to my usual site, Open Source. But, here's what happened:

Open Source Main Page - Not Logged in

This looked normal, I just needed to log back in. So I did...

Normal Log in Page

And clicked "Sign up using Google"

It asked me to log in, using the normal Google page. I did, but it didn't actually "log me in", the top still said "Join this Community", even if I navigated the site around a little. It even logged me in to my normal google account, going to mail.google.com took me straight to my email. Thinking of a sneaky way, I thought of using chat. I signed out of Google just to be safe.

Chat Page

Chat Login Page

It asked me to log back into Google...

Munchlax!!!!!!!!!!!!!!!!!!!!!!!!!

But that never worked.

I got the idea to get an account on my normal parent account for a site which I have never been to. Of course, I tried something relevant, and picked a new site that looked cool: Home Improvement. It gave me hope...

Home Improvement gives me hope...

But doesn't work after all...

No diy

I even tried a site where I just got an account because it looked cool: Freelancing

Freelancing Home page

But like everything I do, it doesn't work.

Incredibly mad (and tired) at this point, I go back to Area 51, and try there. And the result, was quite surprising:

I'm back on a planetary Area 51

And I was back! It didn't work on any other sites, but Area 51 was giving me hope. Making sure, I want to log out, and log back in.

Stack Auth Log out

That was a terrible mistake.

No more dropdown

I couldn't get back in.

Trying again, I went back to chat, and this "unregistered" user that I had previously used to figure out how to follow on Area 51 was there, and thanks to the 50 rep it earned from having the email verified. It wouldn't logout, no matter how many times I've tried. If you want to see pictures of that, let me know.

This isn't a very pretty bug, and although it's uncommon, it's made me quite miserable. I'm not sure what is really causing it. If you want to try this, I strongly encourage you to. It's a very exciting journey :D

Also, if you're a community manager, you might want to find a very suspicious "User142319" that has followed my Urban Planning Proposal. You might want to take them out, and destroy this "user." Not saying anything would be... like destroying the universe (It's Area 51, you never know!).


Alright, if anyone dares to try this (and I very, very strongly encourage you to go through this), you can fix by clearing any website data that is marked under stackexchange.com. Now, that there's a known fix, go ahead and try it! :D

  • 6
    umm... you know you could ask the same thing in one line: "please merge [user here] with my main account". Nice story, but Area 51 being buggy is well known fact. – ShaWiz Aug 23 '15 at 5:51
  • Yeah, Area 51 is "here be aliens". I have two accounts there, and it insists on logging me into both at the same time (1 vs 51 rep in topbar vs profile)... – user259867 Aug 23 '15 at 6:55
  • Out of curiosity, do you guys hae any idea how to fix this? I've literally tried everything imaginable. Oh, and feel free to edit the post too, it's an absolute pain to even try – Zizouz212 Aug 23 '15 at 15:24
  • Also, the +100 goes to far over the right of the drop-down menu, at the very top. – HDE 226868 Aug 23 '15 at 15:27
  • @HDE226868 I blame Safari. – ArtOfCode Aug 23 '15 at 15:28
  • I was thinking about getting another browser anyway. Best votes browser wins!!! – Zizouz212 Aug 23 '15 at 15:30
  • 6
    You wrote all this, including images, on your mobile? Impressive.. – enderland Aug 23 '15 at 15:30
  • @enderland I uploaded the images using the "unregistered" user on Area 51, but I wrote the entire thing on my phone (and copied the images after) – Zizouz212 Aug 23 '15 at 15:52
  • 1
    Interesting. I have a theory for what happened here, but it only makes marginal sense since Area 51 should not affect things in such a drastic manner... Key word being "should". I'll try to reproduce this, but in the meantime, I can leave everyone with one important life lesson that will help you elsewhere on the Internet as well: If you want multiple accounts, don't use the same browser. Or at least log out first. (Not using Safari is also a decent idea. :)) – Adam Lear Aug 23 '15 at 17:08
  • @AnnaLear Thanks. It's quite weird, because I tried logging out of chat (which did nothing for this new account) and it wouldn't log me out of Area 51 and discussions for the longest of time. I only managed to get back on after clearing my website data (for stackexchange.com) – Zizouz212 Aug 23 '15 at 17:11
  • Also, did you try to paste the synthetic-open-id thing into the openid field on A51 to log in? Is that what this screenshot is? That's just something we use to track creds internally and you can't actually use it to log in anywhere. Which brings me to my next question... where did that URL turn up? – Adam Lear Aug 23 '15 at 17:12
  • @AnnaLear When I finally got to Area 51 with my google account, I tried logging out and back just to make sure, and when I logged out, that's what popped up. (I never managed to get back in afterwards) – Zizouz212 Aug 23 '15 at 17:13

You must log in to answer this question.

Browse other questions tagged .