1

The traffic graph on the new /site-analytics page doesn't display the correct timeframe if you select very long time periods.

Steps to reproduce:

  • Have 25k reputation or a diamond on Arqade
  • Visit https://gaming.stackexchange.com/site-analytics
  • Select either private beta, public beta or graduation as starting date, leave the current date as end date
  • Observe that the traffic graph only goes until 2013

This only affects the traffic graph, not the other two on the page

  • This is due to an unfortunate limitation of the Google analytics core API - a maximum of 1000 rows of data (in this case, one row per day). See developers.google.com/analytics/devguides/reporting/core/v3/… - I was not aware of this limitation until investigating this bug. – Oded Sep 7 '15 at 15:44
  • @Oded It looks like you can ask for more than 1000 results by adjusting that parameter, though not for more than 10000. – Mad Scientist Sep 7 '15 at 15:46
  • Ah - I need to read better (or possibly clean my glasses once in a while) - I saw the 10,000 and read it as 1,000. – Oded Sep 7 '15 at 15:47
3

The data for the traffic graph comes from Google Analytics.

I did not realize that the API limits the result set to 1000 by default, which is what caused this bug.

I have made a change to ensure we get the complete range, so once the cached results are cleared, the graph should display fully.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .