1

Most of the links on stackoverflow are not working. I suspect it is due to a js that is not being loaded.

I am getting following error in console. Can anyone please suggest on how to get rid of this error?

enter image description here

The problem occurs only for stackoverflow dropdowns/links. No issues in other communities.

The problem occurs in chrome and FF. Please note, I logged into stackoverflow using FF for first time.

  • 3
    What is your exact url you are using? – Patrick Hofman Sep 12 '15 at 6:26
  • stackoverflow.com/tags – Nikhil Aggarwal Sep 12 '15 at 6:27
  • 1
    Just as a side note: the page work here. Are you blocking some javascript? Ads maybe? – Patrick Hofman Sep 12 '15 at 6:28
  • I have checked the settings and I confirm that I am not blocking javascript. – Nikhil Aggarwal Sep 12 '15 at 6:30
  • e.g. - Achievements drop down is not opening only in stackoverflow. In other communities it is working. Similar issue with other drop downs as well. – Nikhil Aggarwal Sep 12 '15 at 6:40
  • @PatrickHofman - Are you able to click on the Achievements dropdown. Does it work on the page I mentioned? – Nikhil Aggarwal Sep 12 '15 at 6:53
  • Yes. It all works normally. – Patrick Hofman Sep 12 '15 at 7:02
  • @PatrickHofman - Great. Any suggestions for me as how can I resolve this issue? The problem is all browsers on my machine. – Nikhil Aggarwal Sep 12 '15 at 7:03
8

First, that javascript loading isn't from StackExchange. Something is in the middle fiddling with your request.

The IP address mentioned belongs to an Indian telephone company, and the host name can't be resolved at the time. If you know the company hosting mtnl.net.in you might have a clue what the source of the problem is (some networking information). Is it your ISP? Have you got an not very up to date router which was compromised? Maybe your work that tries to fiddle with your Internet requests?

Second, maybe the missing javascript isn't the actual issue with your not-working StackOverflow. Can you check the errors in the console tab? Can you try to browse StackOverflow over HTTPS?

  • 1
    https works like charm. Additionally yes, mtnl is my ISP. What should I do to fix the problem due to this? – Nikhil Aggarwal Sep 12 '15 at 13:47
  • There is a problem - Whenever, I navigated the protocol changes back to http and then again some problems. I need to fix it badly. – Nikhil Aggarwal Sep 12 '15 at 13:52
  • 3
    Contact your ISP. Or change it immediately. This sounds suspicious... – Patrick Hofman Sep 12 '15 at 14:01
  • 4
    Well ISP tracking and messing with traffic is not surprising, but I would expect it more in places like China or Iran... – Shadow The Princess Wizard Sep 12 '15 at 14:38
  • 2
    MTNL is a known code-injector. – Martin Tournoij Mar 7 '16 at 4:23
7

Based on your screenshot, most likely you got some malware on your machine that try to load a resource called "getjs", which is not part of Stack Exchange.

Run full virus scan, malware detection program, etc, and it would hopefully be resolved.

  • I have tried doing that. But no success. There is an issue only with stackoverflow.com. – Nikhil Aggarwal Sep 12 '15 at 7:41
  • Still, something on your end. Might even be on your ISP side. Try different computer, different connection, and see. – Shadow The Princess Wizard Sep 12 '15 at 7:46
  • I tried checking on different computer and the same problem again. Let me check all possible options suggested and will revert back. – Nikhil Aggarwal Sep 12 '15 at 7:52
  • Well things worked fine with my friend who is using other ISP. And as suggested by Patrick, things worked fine over https. – Nikhil Aggarwal Sep 12 '15 at 13:50
  • @nikhil so it is most likely your ISP, cheers for finding a workaround! :) – Shadow The Princess Wizard Sep 12 '15 at 14:54
  • Thank you for your help :) – Nikhil Aggarwal Sep 12 '15 at 15:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .