29

I registered this ID with my Gmail account, and logged in successfully via web browser. However, while I was trying to log in on the Stack Exchange app in my Android Phone, I don't see any option to log in with Google:

I was told that no user was found with my Gmail account. It is amazing that I can log in via web browser, but cannot do so with the same Gmail account via app. How can I do that?

Just to compare, here is a "normal" login screen of another user:

Where did the Google login go and how can I bring it back?

My app version is 1.0.73, phone is Coolpad 8150D with Android version 4.0.3, kernel 3.0.8.

  • Do you have more than one Google account? Did you remove some built-in apps from your device? Also, please include exact device you have and app version – Shadow The Dragon Wizard Sep 17 '15 at 13:38
  • I just have a Google account, and log in by click on the Google button via web. However, there is no Google button in app. And the app version is 1.0.73.My phone is Coolpad 8150D with android version 4.0.3 and a kernal version 3.0.8. – TJM Sep 18 '15 at 4:55
  • Weird. Can you take screenshot of your login screen? That is what I have: i.stack.imgur.com/MJLzF.png – Shadow The Dragon Wizard Sep 18 '15 at 7:21
  • That is:link – TJM Sep 18 '15 at 8:43
  • So weird. I know that Facebook login requires the facebook app to be installed, so probably it means Google login also needs some app. Did you remove anything from your phone? Do you have google app(s) on it? (being android those come pre-installed, that's why it's so weird) – Shadow The Dragon Wizard Sep 18 '15 at 9:18
  • Anyway, this explains why you can't login, the Stack Exchange is totally different OpenID provider, the username and password there are not your gmail user/password – Shadow The Dragon Wizard Sep 18 '15 at 9:23
  • Originally, there is no google apps(s) or play store installed on my phone, when I bought it. There is only one application source called Coolpad Store, which have nothing in common with google. And time passed, the Coolpad Store refuses to work because it alarm that the version is too old to use and I have to update it. However, after I updating it, it can not run! I click on the Coolpad Store, then the screen become black. After a few minutes, the Android OS alarm a message reading there is no response to this application and ask me whether to kill it. – TJM Sep 18 '15 at 9:58
  • I have called the provider however, they said this kind of phone is out of date and is not maintained now. I once asked them whether I can install the google store, but they say it is not their business. – TJM Sep 18 '15 at 10:00
  • I have called the provider however, they said this kind of phone is out of date and is not maintained now. I once asked them whether I can install the google store, but they say it is not their business. So, I tried to install the Play Store 3 month age, and succeed. However, I cannot run the Play Store. After I clicking on it, there is a fast flash with dark screen and the OS alarmed my that the Play Store has terminated. I tried a few times, but ended up in the same situation. – TJM Sep 18 '15 at 10:07
  • 1
    So I fear you have to get new device with Google app on it in order to login via Google. – Shadow The Dragon Wizard Sep 18 '15 at 10:08
  • One week age, I have tried to install the newest Google, however, I found is amazing that I can not install anything from the online store. – TJM Sep 18 '15 at 10:09
  • Ok, but I still hope that the stack overflow can allow Google users get an additional local ID with the same account, and log in without any other account provider. – TJM Sep 18 '15 at 10:11
  • Doubt it is possible, but let's hope a dev come over and clarifies this. – Shadow The Dragon Wizard Sep 18 '15 at 10:12
  • Okay, i will try. – TJM Sep 18 '15 at 10:14
  • 1
    @WarrenFaith I'm on Android 6.0 as well. I needed to grant permissions to the SE app in order for the google login to appear. – A--C Oct 7 '15 at 17:10
35

I am running Android 6.0 and I needed to grant the Stack Exchange application access to my contacts for the Google login to appear:

Settings - Apps - Stack Exchange - Permissions - Contacts

SE app permissions

  • 10
    Worked for me - this is clearly a bug with the app not fully supporting android 6.0's new permissions set up. – Novocaine Oct 22 '15 at 13:18
  • 2
    That's terrible UX. Spent awhile trying to figure this out while setting up my new 6P. This did work but the button should always be showing, considering it's an android phone and pretty much requires a google account to function to an acceptable standard. Utterly peculiar that they upgraded to supporting Android 6.0 and didn't bother to ask for permissions, they are synonymous. Anyway I won't turn this into a rant. – RED_ Nov 6 '15 at 23:52
  • It has been fixed since then. As of 1.0.81, the app will prompt user to allow accessing the contact on Android M. – Meta Andrew T. Jan 21 '16 at 7:50
3

This has been fixed as of version 1.0.83, which went live February 12, 2016. Sorry I forgot to update the bug report about it. It was due to Android 6.0's new permissions model, which required us to completely overhaul how we did Google login in the app.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .