24

Check. It. Out.

Thing

Open Source has a blog. Or do they? I've already found it slightly unusual that Open Source even has a blog. No announcements, so I was skeptical. But as curious and adventurous I am, I go and look.

enter image description here

What? Stack Overflow? Ew! I wanted Open Source! Open Source doesn't have its own blog? Outrageous!


Getting serious now, this seems to appear for all sites, whether or not they have community blogs. If the site does actually have a community blog in practice, then it works fine, I can get to that community blog.

Why is this a bug?

That's a good question. Is that link even supposed to be there?

If it isn't, then great. Of course, there's always the chance that this red tag will appear...

Well, then I urge you to reconsider. The fact that there is a link to a "blog" that isn't even run by the site is ridiculously misleading. Not only that, but now that Stack Exchange is now Stack Overflow, it can confuse users: Have I gone to a blog that is run by the Stack Overflow site instead?

To make things worse, SE doesn't even allow community blogs anymore. Unless of course, a site already has one, there's no way that new sites are going to ever have a blog, reducing the need for that link. Thanks Catija for pointing that out!

  • 7
    Particularly considering SE won't allow sites to have blogs (if they didn't have one already) any more. It's like a tease... Ooooh, lookie... blog!... just kidding! – Catija Sep 22 '15 at 21:23
  • @Catija Good observation. I haven't thought of that either. – Zizouz212 Sep 22 '15 at 21:24
  • 1
    @Zizouz212 your question has a valid point but the stmt '(and why would you change that?!?)' may attract down-votes. May be you should remove that. FYI, I have upvoted you. – HackerKarma Sep 22 '15 at 21:38
  • 2
    @HackerKarma Yeah, didn't realise I was going on my mini rant about name changes... -_- | – Zizouz212 Sep 22 '15 at 21:38
  • 3
    Pretty sure that's how it worked for a long time now. The recent changes to the main blog + the company rename definitely make this experience more jarring, though. – Adam Lear Sep 22 '15 at 22:32
  • Hmm... Maybe it's just me, but I haven't noticed this entire time. I definitely don't recall this being up though :/ – Zizouz212 Sep 22 '15 at 23:03
  • @Anna, I'm sure this will have been considered (but just in case) the blog link is present on 3rd party (ish) sites, like Ask Ubuntu. Are they aware/agreed to links to Stack Overflow's blog? – James Sep 22 '15 at 23:07
  • @James The blog link to the Stack Overflow blog appears there as well it seems. If it wasn't there before, it could be a bug that is network wide, because I've never seen the blog link on sites that don't have blogs. :/ – Zizouz212 Sep 22 '15 at 23:09
  • 2
    I honestly can't remember one way or the other. :/ But I can't see anything in the code that'd make us not show them earlier. It's also possible that I'm misreading all the things. I'll take another look tomorrow with a fresher set of eyes. Either way, I agree - the current state is suboptimal. – Adam Lear Sep 22 '15 at 23:22
  • @Zizouz212 Like many things brought up in questions here on MSE, I have no idea whether I have previously seen and ignored this blog link, or I'm just noticing as it's new. – James Sep 22 '15 at 23:24
  • @Catija Do you have a link to that info regards no more new per site blogs, please? – James Sep 22 '15 at 23:34
  • @James I looked for it earlier but couldn't find it. I do remember discussing it on Movies & TV Meta when we graduated in January. I'll look some more later though. Oh, here it is. – Catija Sep 22 '15 at 23:36
  • @Catija Thanks :) will cleanup comments here (sorry for the pings Zizouz212) – James Sep 22 '15 at 23:53
  • 2
    @AnnaLear I'm pretty sure it's always been there. Mostly I ignore it because I know the sites I use don't have blogs. – Catija Sep 23 '15 at 4:54
  • 2
    @Catija: Yeah, it's always been there pretty much since the new topbar was introduced. And I've just realized that I'd never noticed how many SE sites do have actual community blogs, because I've always treated that link as just repetitive noise to ignore. – Ilmari Karonen Sep 23 '15 at 6:28
7

Yeah... this turned out to be unintentionally more jarring than necessary. We're doing two-ish things as of the next build:

  1. The "blog" link beside the site name will only appear if the site has a per-site blog in our Blog Overflow system.

    "blog" and "chat" links will be swapped around so that the link order is consistent as much as possible regardless of the blog situation.

  2. There will be a "company blog" link further down in the site switcher, in the "more stack exchange communities" header.
  • 1
    YAAAAAAAAAAAAAAAAAAAAAAAAAYYYYYYYYYY!!!! – Zizouz212 Oct 8 '15 at 1:08
-2

This blog link has been in existence since we introduced the . It's always been pointing at the company blog, which is now Stack Overflow themed, since we changed our name.

  • 10
    This answer is correct and useful, but I concede that it doesn't help folks frustrated or confused by the behavior. We'll discuss proposed solutions next week. – Shog9 Sep 25 '15 at 0:00
1

For the impatient, here's a bit of user CSS to fix this:

.topbar .current-site .related-links a[href*="//blog.stackoverflow.com"] {
    display: none;
}

This will hide the generic fallback links to blog.stackoverflow.com, while still showing the blog link for sites that actually have a custom community blog.

Obviously, this CSS should not be injected on stackoverflow.com itself or its subsites (meta.SO and careers). Also, it won't hide the blog link here on meta.SE, since the one here actually points to blog.stackexchange.com, even though it redirects to the same place. That might be considered either a feature or a bug.

(And yes, this is totally going into the next version of SOUP. In fact, it's already in the devel branch.)

9

Agreed on this.

The blog link in the drop down is in between two other links ("Chat" and "Logout") which are both relevant only to the site being viewed, so the logical impression derived at is the "Blog" link would also be related to the site being viewed.

  • Bad UI - One link with two different destinations depending on which site you're on but without the different outcomes being identified
  • Bad UX - For users expecting the local blog
  • Bad UX - For users expecting the main blog because they've used the link but never on a site which has it's own blog

Whether bug or bydesign (so feature request), it would be nice to have it changed. The blog link to be present when the site being viewed has it's own blog, and otherwise just no link.


Also related is a new feature request I raised after reading this.
Add a link in the top bar to the main blog

Changing both this request here and implementing my idea (or even something similar) would produce a good overall UI for accessing the different blogs.

3

This is now my new pet peeve.

I'm a fan of selectively doing away with this. Why? Because there are cases where third-party blogs exist (as James said). For example, Worldbuilding has a blog hosted by Medium called Universe Factory. It can be hard to get to if you don't know that it exists, which might be lowering readership from Stack Exchange users.

I suggest that we keep the button for sites that have third-party blogs, but make it a link to said blog.

  • So almost like a mod-configurable button to point to a third-party community blog run by the site? Interesting :/ – Zizouz212 Sep 22 '15 at 23:16
  • @Zizouz212 Yeah, pretty much that. – HDE 226868 Sep 22 '15 at 23:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .