8

There appears to be network-wide problem with the gravatars. For some users, the generated gravatar is replaced by the Gravatar logo (a tilted capital G).

It seems to occur both in the question list or question/answer footer (where the smaller version is displayed) and on the profile page (where there is a larger gravatar), but not necessarily simultaneously for the same user. For example, my generated gravatar is shown when I browse my old posts, but that tilted G has replaced my profile picture.

Tested browers: Chrome, Internet explorer. Does not happen on my iPhone running GC.

Pics:

My profile page:

enter image description here

Question list:

enter image description here

  • Your gravatar is showing up just fine for me in this question. Go look at gravatar.com/avatar/… and see if it's working for you. Probably a temporary issue if anything. – Adam Davis Sep 25 '15 at 21:35
  • @AdamDavis Have you had a look on my profile page too, or just in the footer of the question? – Daniel R Sep 25 '15 at 21:36
  • It's showing up on your profile just fine as well, both here and on photography. Maybe a localized issue to you and your network? – Adam Davis Sep 25 '15 at 21:38
  • Ah, I'm getting the same problem here: photo.stackexchange.com/questions?sort=newest – Adam Davis Sep 25 '15 at 21:38
  • Still experiencing this problem, and I'm using a different browser/os/device/network than yesterday. – Adam Davis Sep 26 '15 at 11:49
  • Appears to be bug on gravatar's side, not much SE can do in such case. Any reason you insist on using it instead of uploading the picture to Stack Exchange? – Shadow The Curly Braced Wizard Sep 26 '15 at 17:43
  • @ShadowWizard Well, I don't care that much personally, and I don't know anything about the underlying machinery (apart from what I learned from the answers to this question). But I thought it might be a good idea to let SE developers and others know what I noticed anyway. Just to be clear, I don't care anything at all about my own gravatar. It's the borkage of the gravatars for new users and others which is the issue, and something that can affect the overall UX, and hence might be interesting to SE staff. – Daniel R Sep 26 '15 at 17:59
  • anybody still seeing this issue? no repro here.. – m0sa Sep 28 '15 at 8:12
  • @m0sa Yes, on my PC (Win 7) I still get this behavior, but still no repro on my iPhone. – Daniel R Sep 28 '15 at 9:39
5

The page you're having trouble with is the newest questions page on photography.SE, and it's using a different hash than the ones elsewhere:

Here's the icon from that page:

https://www.gravatar.com/avatar/2c2360159126f411d9f2764fe55b7f4d?s=32&d=identicon&r=PG

enter image description here

Here's the icon from the page we're on right now:

https://www.gravatar.com/avatar/29dcd31b9a6882bf854300080f90c583?s=32&d=identicon&r=PG

enter image description here

So the hash is different, however the icon is showing up on your photography profile page, and the hash is the same:

https://www.gravatar.com/avatar/2c2360159126f411d9f2764fe55b7f4d?s=128&d=identicon&r=PG

enter image description here

It's the same hash as the other photography hash but a different size, so here's my analysis:

  1. You have a different email registered for your photography.SE account than your meta account. I'm guessing you changed your email there recently?
  2. Gravatar hasn't generated your 32x32 version of your gravatar, or it's not cached/caching properly.

At any rate, stackexchange can't really do anything about it, it's up to gravatar. If it really bothers you, register for gravatar and use this image: https://www.gravatar.com/avatar/2c2360159126f411d9f2764fe55b7f4d?s=512&d=identicon&r=PG this will then force Gravatar to update all their cached sizes for you, and it should start working. If you don't want to register for Gravatar, you're stuck with whatever they choose to do, or not do, for your icon.

Given that it is happening for a lot of 32px gravatars, I'm guessing it's a caching issue and should be resolved in time. Further, the image for the requested 32px image is obviously larger, again suggesting a problem with gravatar, and nothing to do with Stack Overflow Inc.

Also note that this is the default image when d=identicon is not included in the URL. That parameter is what tells gravatar to use an identicon when a user doesn't have a registered gravatar. Note that it is present in all the links above.

3

Not a solution, but another observation.

The gravatar for Dan Holzner is wrong at size 32:

size=32: Dan Holzner's gravatar

Note that it is actually 80x80 pixels in size, too.

But using the same hash is okay at other sizes:

size=16: Dan Holzner's gravatar
size=64: Dan Holzner's gravatar
size=128: Dan Holzner's gravatar

and the same for 256 and 512.

1

Your Gravatar is working just fine for me - check your connection to the Gravatar servers, as it is probably a problem with your machine not being able to download the gravatars.

  • The same thing happens both on my home computer and at work though. – Daniel R Sep 25 '15 at 21:39
  • 3
    It clearly is an intermittent problem: i.stack.imgur.com/db4VC.png – rene Sep 25 '15 at 21:39
0

I assume this a cache issue. Gravatar's logo is well... your current profile picture. With rene's comment that this is affecting multiple users, there must be a problem with Gravatar, not Stack Exchange at the moment.

This is probably due to caching on Gravatar's side or as Adam Davis said, a hashing issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .