17

Odd CSS link colors have appeared again on at least some of the sites without the CSS update, specifically including Science Fiction & Fantasy and Mi Yodeya, and likely others. User profile pages also have broken layouts.

I believe it's related to this previous bug report:

Problems with SF&F and Seasoned Advice SE CSS

This time, Seasoned Advice is not affected as they've had the CSS redone.

  • Here's the Mi Yodeya meta post -- third time this has broken on us now. I suspect that the nine graduated sites on this list are all affected, but I don't know their styles well enough to know if what I see today is different from what I would have seen yesterday. – Monica Cellio Oct 2 '15 at 16:19
  • User profile pages are also wacky. – Keen Oct 2 '15 at 16:41
  • The Christianity link colors changed today. If that was not intentional, then it is also messed up as @MonicaCellio speculated. Also, the profile page doesn't line up properly as Keen notes. – ThaddeusB Oct 2 '15 at 18:16
  • Thanks for checking, @ThaddeusB. Your site is pretty blue to begin with and I wasn't paying attention, so I didn't know if this was a change. I'd say evidence points to some recent change only working on sites with the new base CSS, which is most but not all of them. – Monica Cellio Oct 2 '15 at 18:25
  • @MonicaCellio I've found topics related to this on a couple of the other sites including Electrical Engineering and Skeptics. – Catija Oct 2 '15 at 18:27
  • @Catija I've added links to the earliest reports I know of from four of the five sites mentioned here. If you've got a link for SFF please feel free to edit it into my answer. Knowing when things broke could be helpful in debugging, maybe. (I don't know how often they push updates, but I have the impression it's often.) – Monica Cellio Oct 2 '15 at 18:39
12

LESS includes are a dangerous thing. :) The issue should be fixed now.

On the upside, we are killing the site redesign backlog, so hopefully these issues won't be coming up ever again before too long.

  • 4
    Glad to hear the good news on the backlog. I've been looking forward to some of those profile changes! – Monica Cellio Oct 2 '15 at 20:26
15

So far problems have been reported on 5 sites: SFF, Mi Yodeya, Christianity, Electrical Engineering, and Skeptics. What those sites all have in common, and what turned out to be the culprit the first time this happened on one of those sites, is the lack of base CSS. There are currently nine sites listed as not having the base CSS updates yet:

  • Photography
  • Wordpress Development
  • Role-playing Games
  • Electrical Engineering
  • Physics
  • Science Fiction and Fantasy
  • Skeptics
  • Mi Yodeya
  • Christianity

I suspect that a recent change was pushed that, unknown to its author, depends on the base CSS being present. Last time it was the image uploader. I've no idea what it might be this time, but with luck those with access to the revision logs can narrow it down. I've linked the earliest reports (of the current iteration) that I know about in case their timestamps are helpful.

  • This is also happening on Area51 - but that's never going to get the base CSS! :/ – ᔕᖺᘎᕊ Oct 2 '15 at 19:49
  • Ah, ok. Since Area 51 is its own thing, it might be worth a separate bug report for that. – Monica Cellio Oct 2 '15 at 19:51
  • @ᔕᖺᘎᕊ Got a screenshot for that? I don't see these issues on A51 (and yeah, a separate report would be best for that since A51 is a separate codebase, so the cause is likely different.) – Adam Lear Oct 2 '15 at 20:02
  • @AnnaLear seems to be fixed now...!? I definitely saw it though! – ᔕᖺᘎᕊ Oct 2 '15 at 20:04
  • 1
    @ᔕᖺᘎᕊ No worries. Grab a screenshot if you see it again. :) – Adam Lear Oct 2 '15 at 20:05
  • :( You missed RPG SE, where I believe my report was earlier than any of those you do link! :P – KRyan Oct 2 '15 at 20:10
  • @KRyan I didn't go hunting them; I just harvested them from comments here. Sorry for missing your trailblazing report! – Monica Cellio Oct 2 '15 at 20:25
  • 1
    Heh, my fault for being too lazy to bring it here to begin with. – KRyan Oct 2 '15 at 20:26
2

It seems that the 'about me' section problem is because the .user-show-new .user-header .user-about-me style has a width: 430px; which is just too big for the current layout.

This (or the overall width) must have been changed. Removing this attribute, or changing it to max-width: 430px; seems to fix that issue:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .