5

This question already has an answer here:

Last night I decided to upgrade my phone to Android 6.0 and noticed I am unable to log into the app anymore. I have always used Google as my login for the site and I was logged into the app just yesterday, before upgrading to 6.0.

I double checked that I don't have a password associated with my account by using the "forgot" link and did get back a confirmation email saying that I don't have a password associated with my account and that I can login using my Google account.

Yet this is what my login screen looks like on my 6.0 phone.

Android 6.0 Login Screen

And on my 5.1.1 tablet it looks like this.

With Android 5.1.1]

Looks like a new permission model issue causing the Google login not to show up on Android 6.0, and because I do not have a password associated with my Stack Exchange account, I am unable to login.

marked as duplicate by ShaWiz, Werner, Ward, rene, Flyk Oct 13 '15 at 22:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Have you checked if the "Contact" permission is allowed for Stack Exchange app? You can check by going to "App info" and then go to "Permissions". – Meta Andrew T. Oct 6 '15 at 17:46
  • No Permissions granted; however I was able to manually enable it and that worked. Since I did a fresh install of 6.0 and had all of my apps restored during the phone setup process figured I'd try deleting all data and trying again but that did not work. I didn't think of enabling the permission manually so thanks for that! Anyone know if the Storage Permission is needed? – hoss Oct 6 '15 at 17:57
  • 1
    @AndrewT. sounds like it's worth an answer. :) – ShaWiz Oct 6 '15 at 17:57
5

Update: as of v1.0.77, the app will show Log in using Google regardless if Contact permission is enabled or not. If it's disabled, the app will prompt the user to allow accessing the contact.

login selection contact permission dialog

Fixes an issue that didn't allow Google sign-in on Android 6.0 devices


tl;dr go to Stack Exchange's "App info", open "Permissions", and enable "Contact".

Android app needs Contact permission for managing accounts on their device, including detecting and using existing Google account as login credential.

Since Android 6.0, the permission model is changed so that users can now directly manage app permissions at runtime.

It seems there's a bug in Android when a user does a fresh install of Android 6.0 (compared to just updating), where permission settings might be lost after restoring the apps. (not yet proven, but similar issue already occured)

You need to manually enable the contact permission by:

  1. Access the "App info" (either by dragging the app from launcher to "App info" on the top, or from Settings - Apps - Stack Exchange)
  2. Open "Permissions" setting
  3. Enable "Contact" permission

Now you should be able to use Google for login credential again.

  • Thanks for this information, I did try clearing cache/data and that also did not work, so it seems like an issue with the app. I looked through some a number of other apps and it looks like 1 or 2 had the the same issue. – hoss Oct 6 '15 at 18:31
  • Updating the app with the latest version of the Google Sign-In SDK will completely eliminate this issue: android-developers.blogspot.com/2015/11/… ... API update is pretty straightforward: android-developers.blogspot.com/2015/12/… – Steven Soneff Mar 20 '16 at 4:38

Not the answer you're looking for? Browse other questions tagged .