11

When I look at my rep, there is no tracker saying my next privilege. However, this only happens on my hardware recs profile. On any other stack exchange sites, I see it, clear as day. Why is it gone? As you can see below: No rep tracker!

No rep tracker

11
  • This got nothing to do with reputation, it is part of the new profile page design which is used to track the next privilege, not reputation. Oct 14, 2015 at 11:19
  • @ShadowWizard oh.
    – Rubydesic
    Oct 14, 2015 at 11:19
  • I also don't see it on your profile there, though it shows up for me in my own profile. Bug indeed, hope a dev will see this soon. Oct 14, 2015 at 11:21
  • @ShadowWizard: I do not think it is. I see the same phenomenon on the OP’s profile, where I should see the next privilege. I guess however, that it may have something to do with Hardware Recommendations entering public beta.
    – Wrzlprmft
    Oct 14, 2015 at 11:21
  • @Wrzlprmft the profile you linked to is my profile?
    – Rubydesic
    Oct 14, 2015 at 11:22
  • @John Lee: Yes, and in contrast to Shadow Wizard, I also see what you see.
    – Wrzlprmft
    Oct 14, 2015 at 11:23
  • @Wrzlprmft How interesting. I also noticed that this profile has the same issue on hardware recs.
    – Rubydesic
    Oct 14, 2015 at 11:24
  • 4
    @John did you choose by any chance "Track a tag badge instead" at some point? According to this open bug report, this indeed cause the whole thing to disappear. :/ Oct 14, 2015 at 11:29
  • @ShadowWizard :| are you kidding me? I may have done that, I'm still a newbie, I didn't know clicking on things could be dangerous :(
    – Rubydesic
    Oct 14, 2015 at 11:31
  • Of course, nobody can know. That's why it's called a bug. :) Oct 14, 2015 at 11:36
  • @ShadowWizard lol I hope they can fix it soon!
    – Rubydesic
    Oct 14, 2015 at 11:39

2 Answers 2

3

I might have found a workaround, until the bug is fixed. Brace yourself, it's awkward, but it might just work. :)

  1. Go to the Ask Question page, e.g. https://hardwarerecs.stackexchange.com/questions/ask
  2. Open your browser's dev console:
    • for Chrome, it's F12 ➔ Console
    • for Firefox, it's right-click ➔ Inspect Element ➔ Console
  3. Type this into the console and press Enter:

    $.post("https://hardwarerecs.stackexchange.com/users/activity/set-first-tracker/3", {"fkey": $("#fkey").val()});
    

You should see "Object {readyState: 1}" response, and hopefully your privilege tracker will be back.


For those who wonder, this imitates going to the profile page and choosing "Track my next privilege", when the tracker is there. And luckily, it also works when it's gone.

3
  • ooook. Interesting =P
    – Rubydesic
    Oct 14, 2015 at 11:44
  • lol, jQuery is a magic fix. :D Oct 14, 2015 at 11:44
  • oops, sorry for your lost edit @John I was in the middle of my own edit. Added now. Thanks! :) Oct 14, 2015 at 11:47
8

There was an issue where users could choose to track a tag badge, even if the newer site they were participating on had no tags that qualified for tag badges*.

This has been fixed - thanks!

* remember, a tag must have at least 100 questions tagged with it to be a candidate for tag badges.

3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .