8

Upon clicking on SE icon, blue (starting) screen appears and then I am back to home screen, SE app simply won't start. This kind of behaviour never happened before (on any other app).

I tried to remove it from "task manager", reinstalling and logging back in; neither did work.

In Settings -> Stack Exchange -> Notices I found a log message:

FILE DOESN'T EXIST, WILL CREATE: users/dev/buildagent/work/{id}/pods/target support files/pods/pods-ack...plist

  • App Version: 1.4.0
  • Device: iPhone7,2
  • OS Version: Version 9.1 (Build 13B143)

TLDR: app starts when cellphone has no internet access.

I just noticed when I am on 3G (cellular internet) it crashes ASAP, but when I am on wifi that has no internet (for LAN etc.) app starts normally but no new content, when I turn off WiFi and iPhone switches to cellular; app crashes.

Note: I turn off WiFi using control center - so I never leave the app.

Another thing, when I force iPhone to use EDGE (slowest possible internet) app starts, and crashes after 5 seconds or so. I assume when app downloads some data from server.


Known workaround (works for me too)

I found a workaround: turn on Airplane Mode, launch the app, then turn Airplane Mode off. – NobodyNada

15
  • 2
    Same thing started happening to me today. Tried to delete and reinstall - no difference. iPhone 6, 64G, iOS 8.3 . What's going on?
    – Floris
    Commented Dec 8, 2015 at 3:43
  • As of this afternoon, I have the same issue. Crash log: pastebin.com/Jw8bghuQ
    – NobodyNada
    Commented Dec 8, 2015 at 3:46
  • The app works on my end. Are you using the beta or not? Commented Dec 8, 2015 at 7:02
  • I'm getting the same behaviour with the same messages in Settings. No recent update in the App Store list, so not sure what caused it to start. iPhone 6S on iOS 9.1. After app reinstall it stays up long enough to log in, then crashes on the SE home screen.
    – jonrsharpe
    Commented Dec 8, 2015 at 8:01
  • @PatrickHofman I don't even know where to turn on "beta" version, there is no such option in Settings...
    – Kyslik
    Commented Dec 8, 2015 at 8:32
  • Never mind then. Then you are on the official release. The beta works fine. Commented Dec 8, 2015 at 8:35
  • Btw, the "FILE DOESN'T EXIST, WILL CREATE" is a known bug and doesn't affect the application. Commented Dec 8, 2015 at 9:33
  • @PatricHofman Good to know, I just posted whatever I could find. Funny: notifications work fine but have to reply using browser.
    – Kyslik
    Commented Dec 8, 2015 at 9:35
  • 2
    I got the same problem today. I'm pretty frustrated because I use this app A LOT and the crash is nuts. My account is linked to facebook so I don't know if that's causing the problem.
    – Schwale
    Commented Dec 8, 2015 at 11:37
  • @Ale My account isn't Facebook and I still have the problem.
    – NobodyNada
    Commented Dec 8, 2015 at 16:06
  • Hope they fix it soon.
    – Schwale
    Commented Dec 8, 2015 at 16:08
  • 1
    I found a workaround: turn on Airplane Mode, launch the app, then turn Airplane Mode off.
    – NobodyNada
    Commented Dec 8, 2015 at 16:10
  • I just noticed that one of my other apps has the same problem. Maybe it's a bug in iOS?
    – NobodyNada
    Commented Dec 8, 2015 at 16:13
  • This was happening to me on beta a week ago. I ignored it for a day, then installed the latest beta and the problem went away. Hopefully this didn't make it into the app store version...
    – Pollyanna
    Commented Dec 8, 2015 at 16:35
  • @AdamDavis I'm running the App Store version...
    – NobodyNada
    Commented Dec 8, 2015 at 17:17

1 Answer 1

6

This is fixed. There was a bug in the API that was causing certain achievements to have a null link property, breaking an API contract. This caused a hashing function that depends on the link URL being non-null to fail, crashing the app.

4
  • Is this related to the problem with no recent achievements on iOS too? That is still a problem when I checked just now (2015-12-08 18:20 UTC). Commented Dec 8, 2015 at 18:17
  • @JonathanLeffler Probably. Kevin's looking into it. Commented Dec 8, 2015 at 18:40
  • And this one too, as both apps use the same API. Commented Dec 8, 2015 at 18:44
  • Just checked again: scores are back to more or less normal for me on iOS with the app. Commented Dec 8, 2015 at 20:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .