I've come across a problem recently that when I click links to travel between SE sites, like in the dropdown list or the hot questions, the new page is all in plaintext. I've determined that the non-secure http sites are resulting in plaintext, and if I just change it to https things look fine. I am also automatically being directed to the http version when I type in an address and don't specify either (e.g. academia.stackexchange.com).

I'm not sure if this is an issue with SE or with my computer/browser, though I would lean towards the latter. I am using Chrome 47.0.2526.80 on Windows 7.

How can I make it so I automatically go to the secure version of each site?


I tried browsing while looking at the Network tab of devtools. I received two errors while trying to navigate to this HNQ:

GET http://cdn.sstatic.net/gamedev/all.css?v=c6de2a6b54e6 how-can-i-create-borders-in-an-open-world-game:23

GET http://edge.quantserve.com/quant.js how-can-i-create-borders-in-an-open-world-game:3506
(anonymous function) @how-can-i-create-borders-in-an-open-world-game:3506
(anonymous function) @how-can-i-create-borders-in-an-open-world-game:3511

  • Sounds like you have some browser plugin like HTTPS Everywhere that force https URL, while the site is trying to load the CSS from non secure domain, thus failing. Try to disable those plugins while browsing SE sites and see. Commented Dec 10, 2015 at 13:52
  • Which links are you clicking? Because a lot of them should be protocol relative. Maybe a screenshot if it is difficult to explain.
    – rene
    Commented Dec 10, 2015 at 13:55
  • @ShadowWizard As far as I can tell I do not have any plugins running. This is a work computer, so it's basically the defaults for Chrome. Also, this just started happening a day or two ago and had been working fine before that.
    – David K
    Commented Dec 10, 2015 at 14:01
  • @rene The links are the Hot Network Questions, or the "Your Communities" section under the SE toolbar at the top of the page.
    – David K
    Commented Dec 10, 2015 at 14:02
  • @rene yeah, those links are not relative, always point to the http:// version even if you're in https:// Commented Dec 10, 2015 at 14:05
  • @David anyway, can't reproduce what you describe. Try browing between the sites with the Network tab of dev tools open, with "Preserve log" ticked. What resources are failing, and with what error? Commented Dec 10, 2015 at 14:07
  • @ShadowWizard See edit
    – David K
    Commented Dec 10, 2015 at 14:18
  • @David so sounds like an evil/rogue anti virus that break stuff, see here. Commented Dec 10, 2015 at 14:20
  • @ShadowWizard That doesn't surprise me in the least bit. This is a work computer (no admin privileges) with completely overkill security measures. I'm not sure there's anything I can do to fix this on my own.
    – David K
    Commented Dec 10, 2015 at 14:29
  • In that case, you can try the opposite of what I told you before, and install HTTPS Everywhere. This will force the browser to use https, and hopefully the anti virus won't mess with it while in ssl mode Commented Dec 10, 2015 at 14:30
  • @ShadowWizard I do recall a post from AdamLear about links that were still not protocol relative. Am I imagining that or was it discussed in chat maybe because I can't find any reference.
    – rene
    Commented Dec 10, 2015 at 14:32
  • @rene yeah Adam said it's still a work in progress, but only in comments as far as I can tell. Commented Dec 10, 2015 at 14:33
  • @ShadowWizard That worked, thanks! If you want to put that as an answer, I can accept it.
    – David K
    Commented Dec 10, 2015 at 14:37

1 Answer 1


Based on the error you get, I found this is most likely caused by a rogue/corrupt anti virus software, as described in this Stack Overflow answer.

In case you can disable/replace the Anti Virus, this will be ideal and most likely resolve your problem.

If you can't do that (e.g. company computer) then you can force your browser to switch to ssl when possible and replace all the links as well, by installing a browser extension/plugin like HTTPS Everywhere. For Chrome, or Firefox. When in ssl mode, it's much harder for the anti virus to mess with the browser and scan the data it sends/receives, hence good chance it won't corrupt the files.

  • Alas, most meta sites are currently broken when using HTTPS. (Meta.SE and meta.SO do work, though.) Commented Dec 10, 2015 at 17:12
  • @IlmariKaronen but is there no option to configure the plugin to allow exceptions? Commented Dec 10, 2015 at 17:14
  • There is, sort of: you can either enable/disable particular rulesets (easy, but rather coarse-grained; for example, all SE sites fall under one ruleset) or edit the rulesets yourself (requires some knowledge of XML and regexps, and some plugin-specific syntax). Actually, the SE ruleset seems to exclude per-site metas already (and even automatically downgrades them to use plain HTTP), but it still means that the problem described by the OP will likely continue to occur on those meta sites. Commented Dec 10, 2015 at 17:41
  • I see. Well, since it only affects link to hot questions in the side bar, having it working in the main site is more important than in meta sites, so no big deal. Commented Dec 10, 2015 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .