11

When I vote using the Android app, the button highlights briefly in orange as expected and then returns to the normal black (so both vote buttons are the same color). I expected the highlighting to remain in place to show my vote.

The post score reflects my vote, and if I tap the vote button again it cancels my vote (and updates the score again). So my vote is there; it's just not shown. If I vote, navigate back to the list of questions, and then return to the page where I voted, my vote shows in orange and is persistent. Votes I've previously cast show up and are persistent on first view; it's only new ones that behave like this.

By its nature, it's hard to take a meaningful screenshot.

I don't use the app a lot, so I don't know how new this is. My phone says I'm up to date (1.0.77).

4
  • I second this; it's annoying.
    – cat
    Commented Dec 16, 2015 at 2:08
  • @ShadowWizard it's highly related, but in that one the vote is being lost entirely (the count resets). In mine the count is correct and it's just the highlighting that's missing. Commented Dec 11, 2016 at 16:12
  • Nope, the vote is not lost. It says "A reload of the question (pulling the finger down) is needed to show the correct situation" - and I keep bumping into it every time I vote via the app, so I'm 100% sure it's indeed not lost. Just bad design on the app side. Commented Dec 11, 2016 at 16:23
  • Was unclear, sorry -- "lost" in the sense that the page stops reporting it. Anyway, I'm not going to work hard to defend this as a separate question; it's probably the same root cause, and I don't use the app much so I don't know if what I reported a year ago is still the case anyway. It just looks like slightly different behavior; in the one case the number is correct but the vote highlighting goes away, and in the other the number is incorrect (and the vote highlighting goes away). Commented Dec 11, 2016 at 16:28

0

Browse other questions tagged .