2

This question already has an answer here:

! If you have a multiline spoiler, you get a post that looks like this.

! The spoiler tag does not work and breaks on a line break. Neither spoiler works and it immediately converts to a normal "quote."

The expected behavior would be similar to a multiline quote:

Hello

World

except the entire block being converted to a spoiler.


The following also behaves... weird:

Line 1

! Line 2

Converting it to:

! Line 1

! Line 2

Also causes more unexpected behavior (but more expected than the previous example).

marked as duplicate by Shadow, ChrisF, nicael, Gilles, doppelgreener Dec 23 '15 at 17:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

I've experienced this also, and the workaround I found is just insert >! in the empty newline and add to the first line.

>! If you have a multiline spoiler, you get a post that looks like this.
>!
>! The spoiler tag does not work and breaks on a line break. Neither spoiler works and it immediately converts to a normal "quote."

If you have a multiline spoiler, you get a post that looks like this.

The spoiler tag does not work and breaks on a line break. Neither spoiler works and it immediately converts to a normal "quote."

(and yes, it's a bug but it's workaroundable)

  • This is an ok work around I guess. Be nice if this bug just was fixed, though.. – enderland Dec 23 '15 at 16:43

Not the answer you're looking for? Browse other questions tagged .