16

When scrolling through a code-block that is one line high on OSX the scroll bars appear when you hover over to scroll and obscure over half of the text.

Chrome: obscured text Chrome Firefox: obscured text Firefox

It's very distracting. It seems like the addition of some padding to the container <pre> tag makes this disappearing/reappearing scrollbar effect much less obtrusive.

increased padding That's probably a bit much I've added in the screenshot, but I just quickly did it and took the capture. Even if it is just on Mac, it's pretty annoying.

Live example:

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.

Screenshots' source SO post:

https://stackoverflow.com/a/34131942/1252748

Browser versions:

  • Google Chrome, Version 47.0.2526.106 (64-bit)
  • Mozilla FireFox 43.0.2
  • What browser? It might be one that is not supported. – ShaWiz Dec 27 '15 at 7:22
  • @ShadowWizard Google Chrome Version 47.0.2526.106 (64-bit). – 1252748 Dec 27 '15 at 9:51
  • Cheers, so this should be fixed. Please add it to the question as well – ShaWiz Dec 27 '15 at 10:35
  • The post where you saw this? – Braiam Dec 27 '15 at 17:35
  • @ShadowWizard. Added. – 1252748 Dec 27 '15 at 17:44
  • Padding looks ok from Firefox. – Braiam Dec 27 '15 at 17:45
  • @Braiam I've Added that now. – 1252748 Dec 27 '15 at 17:45
  • @Braiam Looks the same for me if Firefox. I added a screenshot. – 1252748 Dec 27 '15 at 17:55
  • Might have to do with themes? – Braiam Dec 27 '15 at 17:59
  • 7
    Eh, seems like disabling overlay scrollbars (System Preferences -> Show scrollbars -> Always) would be the preferred solution if you don't like this behaviour of your OS – Tim Stone Dec 27 '15 at 18:07
  • @TimStone Yes, that's fixed it for me. Thanks! – 1252748 Dec 27 '15 at 18:15

You must log in to answer this question.

Browse other questions tagged .