2

When trying to enter https://stackexchange.com/users/login I get the 'This connection is untrusted' warning from Firefox. I'm currently using internet explorer to ask this question. I have no trouble in accessing http://stackexchange.com/ with Firefox, though.

In the details section:

stackexchange.com uses an invalid security certificate. The certificate is not trusted because it was signed using a signature algorithm that was disabled because that algorithm is not secure. (Error code: sec_error_cert_signature_algorithm_disabled)

If I try to add the exception, I still cannot access the page. Below is the info on the certificate exception I added.

enter image description here

Any help would be appreciated.

  • Please have a look at the certificate in the details dialog. What is the top certificate there? – Deer Hunter Jan 5 '16 at 14:55
  • @DeerHunter , I edited the question. Could you help me? thanks – An old man in the sea. Jan 5 '16 at 14:59
  • Add Security Exception > View > Details > Certificate Hierarchy : what do you see there? – Deer Hunter Jan 5 '16 at 15:04
  • @DeerHunter new edit. ;) – An old man in the sea. Jan 5 '16 at 15:11
  • I have similar issue in my pg too. Simply refreshing make it work fine. – Anirudha Gupta Jan 5 '16 at 16:14
3

Your connection is MITMed by your Avast! antivirus. You can disable that somewhere in Avast! options (like HTTPS filtering or Web/Mail Shield preferences).

  • But why is it that only today I get this error? I've had the avast! antivírus for quite some time now... And why only with firefox? – An old man in the sea. Jan 5 '16 at 15:22
  • @Anoldmaninthesea. - I don't know. Try disabling Web shield/HTTPS filtering and see how it goes. Avast! is a bit notorious for sending out details of your connections (IIRC). – Deer Hunter Jan 5 '16 at 15:29
  • which antivírus would you then recommend ? – An old man in the sea. Jan 5 '16 at 15:30
  • @Anoldmaninthesea. - You can keep Avast! but turn off the MITM thingie. – Deer Hunter Jan 5 '16 at 15:33
  • Should I be worried that they've hacked, or are allowing my pc docs/info to be hacked ? I've just searched the web, and I'm getting a bit restless. =D – An old man in the sea. Jan 5 '16 at 15:42
  • @Anoldmaninthesea. - Yes, that should probably be a concern. I suggest asking on Information Security about it. – Bobson Jan 5 '16 at 15:59
  • 1
    @Anoldmaninthesea. Because Firefox started to show this message if SHA-1 certificates are used only on 1 January 2016. Other browsers probably don't block SHA-1 certificates yet, but as far as I know Chrome will start to do this soon as well. – Mad Scientist Jan 5 '16 at 18:33
0

This appears to be a bug in Firefox itself, which does not yet support the ChaCha20-Poly1305 cipher used by Stack Exchange SSL.

There is an open ticket in bugzilla about it: https://bugzilla.mozilla.org/show_bug.cgi?id=917571

  • Srsly? Why does my connection go through ECDHE-ECDSA-WITH-AES, though? – Deer Hunter Jan 5 '16 at 15:08
  • @DeerHunter no idea, I'm not that deep into the depths of SSL, just analyzed what I could see. – Shadow The Princess Wizard Jan 5 '16 at 15:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .