I recently tried many times to log into Area 51 with my Stack Exchange OpenID. Each time, I got this:

image 1

Then, I went to my OpenID account, and I saw this:

image 2

...what is going on?? I have chrome, and extensions that block 3rd party cookies... is that the problem?


3 Answers 3


I've experienced the same issue since about the time the login system for SE sites changed. I finally managed to go around it.

For me the case of this exact issue turned out to be HTTPS Everywhere. Disabling the addon allows for the login to work without issue. Enabling it again afterwards doesn't cause any issues with the rest of the site.

The root cause of the issue seems to be that the "origin" URL uses HTTP while the "return" URL uses HTTPS. This is clearly seen in the first image provided. This is probably why the URLs don't match.

Because of this I believe that in general some sort of redirection mechanism (in my case HTTPS Everywhere) is causing this issue.

I'm sorry about the terms I use but I'm not familiar with exactly how OpenID works underneat. I hope this still helps to understand the issue.

  • so its sending login data over a insecure connection?
    – Wilf
    Commented Jun 4, 2016 at 20:07


I had the same issue (failed login to Area 51) with a non-SE OpenID account. FWIW my OpenID URL uses a delegate. I could still log in everywhere else on SE.

I switched from Firefox to Chrome and the login worked.

My installation of Chrome is barely configured, has no plugins and I rarely use it, so it also has few security restrictions (e.g. third party cookies), few cookies hanging around, etc. So, this doesn't really diagnose the problem, just suggests that disabling plugins, flushing your current browser and/or using an alternate browser should help.

  • I have chrome, and extensions that block 3rd party cookies... is that the problem?
    – FlipFloop
    Commented Mar 15, 2016 at 16:17
  • @FlipFloop I block 3rd party cookies in my non-working browser, so I think that's worth investigating -- if you disable those extensions, does it work?
    – lofidevops
    Commented Mar 17, 2016 at 12:55
  • i'll try, how much time do you think it will take?
    – FlipFloop
    Commented Mar 17, 2016 at 15:28

Double check if you've got any cookie blocker extensions installed. For example:

  • Adblock Plus Chrome extension


    • Whitelist *.stackexchange.com.
    • Double check Adblock Plus tab in DevTools panel to see what else is blocked.
    • Otherwise disable the extension.
  • DuckDuckGo Privacy Essentials Chrome extension


    • Disable Site Privacy Protection.
    • Otherwise disable the extension.
  • When using privacy web-browsers such as Epic or Brave, make sure they're not blocking any cookies on that page.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .