15

When I'm trying to see all the questions tagged web.config or app.config I'm sent to an URL like:

http://stackoverflow.com/questions/tagged/web.config

which shows an XML parsing error:

XML Parsing Error: no element found
Location: http://stackoverflow.com/questions/tagged/web.config
Line Number 1, Column 1:
^

It's normal from an ASP.NET point of view, but I would like to see those questions instead.

Since adding another tag like asp.net means an URL like:

http://stackoverflow.com/questions/tagged/web.config asp.net

which solves the problem, but restrict the results, I propose to create an empty, meaningless tag which would not restrict the result set but would avoid the errors.

closed as off-topic by CRABOLO, gnat, Martijn Pieters, ale, Aziz Shaikh Jan 3 '15 at 6:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question pertains only to a specific site in the Stack Exchange Network. Questions on Meta Stack Exchange should pertain to our network or software that drives it as a whole, within the guidelines defined in the help center. You should ask this question on the meta site where your concern originated." – CRABOLO, gnat, Martijn Pieters, ale, Aziz Shaikh
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
  • @Shog9: searching is not always a solution. – alexandrul Oct 29 '09 at 13:37
  • also: meta.stackexchange.com/questions/12092/… – Kip Oct 29 '09 at 13:47
  • @Kip: see my updated answer – alexandrul Oct 29 '09 at 13:52
  • 3
    alexandrul: thing is, a solution to this would be good to document as a solution to those other problems. Spreading this discussion around among multiple topics just makes the answers harder to find... – Shog9 Oct 29 '09 at 13:55
  • @Shog9: sorry for not being clear in the first place: searching SO with "web config" in order to find all questions tagged "web.config" doesn't seems to be a nice solution. OTOH, is it possible to move all the answers to a single question in case of duplicates? I've found many nice answers to questions closed as duplicates. – alexandrul Oct 29 '09 at 15:14
  • These tags have been merged and synonyms have been added, so [app-config] and [web-config] are now the canonical tags. – Bill the Lizard Jul 24 '10 at 13:07
6

The solution is re-tagging web.config to web-config. That's how it should look like in the first place.

  • 1
    there are 66 questions tagged with .config :( – alexandrul Oct 29 '09 at 12:36
  • 3
    It's a moderator task ;) – Ladybug Killer Oct 29 '09 at 12:43
  • 9
    the dot is an allowed character in tags, i don't see why the tags should be changed just because the server isn't handling the url properly – Kip Oct 29 '09 at 13:44
  • 1
    @Kip: Jeff's and your opinion differ: meta.stackexchange.com/questions/22940/… – Ladybug Killer Oct 29 '09 at 13:58
  • How do you look for a tag to change them if you can't look for them? Example: .mdf – MPelletier Jul 30 '11 at 16:45
  • @MPel: Let the mods care about it. – Ladybug Killer Jul 30 '11 at 16:49
  • 1
    @MPelletier You can view the questions using a dummy search parameter. – Tim Stone Jul 30 '11 at 16:54
  • @LadybugKiller All the mods did was mark my question as duplicate. – MPelletier Jul 30 '11 at 19:00
4

The error is still present to this day, by the way.

turns up empty, works. Go figure.

3

.Net 4.0 has a solution for this. Please see http://haacked.com/archive/2010/04/29/allowing-reserved-filenames-in-URLs.aspx

  • nice and it referenced stack overflow as well :) – waffles Aug 23 '10 at 2:30
  • @waffles: now that you work for SO any chance you wanna implement this? :D – Thomas Bonini Aug 30 '10 at 3:50
  • 1
    from Phil's article "Please note, that you still can’t request /web.config because that would try to request web.config in the root of your web application and ASP.NET won’t allow that for good reason!" .. we upgraded to .Net 4 and set that flag yet, no dice – waffles Aug 30 '10 at 4:16
  • 1
    I even tried a rewrite rule and could not get it to work – waffles Aug 30 '10 at 4:36
3

Maybe use a quick rewrite rule for the moment: add " +" at the end of the URL if it ends with web.config or app.config or the like.

At least the following URL returns the same number of questions:

https://stackoverflow.com/questions/tagged/asp.net-mvc +

https://stackoverflow.com/questions/tagged/asp.net-mvc

and it also works for the following:

https://stackoverflow.com/questions/tagged/app.config +

https://stackoverflow.com/questions/tagged/web.config +

https://stackoverflow.com/questions/tagged/.aspx +

https://stackoverflow.com/questions/tagged/global.asax +

(but there are no more globax.asax tagged questions)

UPDATE

Another workaround would be inserting %20 after the tag name in the generated URLs, like this: https://stackoverflow.com/questions/tagged/.mdf%20?sort=newest&pagesize=50

  • If it's implemented, I would like to receive a special badge: fixer :D – alexandrul Oct 29 '09 at 13:53
1

My suggestion would be to create a questions\tagged sub-folder and remove ".config" from the script mappings in IIS. Not sure if that is secure or not, tho.

Even though the tags probably should be web-config anyways, I don't think it is a good idea to get an XML parsing error on any reachable URL on the site. This is easily reachable by searching for [web.config].

Not the answer you're looking for? Browse other questions tagged .