32

I just noticed that (suddenly) an SE employee (Kasra Rahjerdi) shows up as a per site moderator on Math Educators see https://matheducators.stackexchange.com/users?tab=moderators

While I would not be opposed if he was actually appointed as a mod on the site, it seems more like a bug to me (no appointment date, and no activity on the site).

What's more this also seems to happen on various other sites (not only beta sites), e.g.:

3
  • 4
    Kasra, moderator for a day. I guess they will revoke his database access now ;) Commented Mar 17, 2016 at 14:19
  • 1
    Yes, 64 sites, which are all the sites he has account on, according to this page. (just search for Kasra) Commented Mar 17, 2016 at 15:13
  • 2
    Now the Accounts tab on his network profile gives an error. Something bad is happening there... :( Commented Mar 17, 2016 at 15:16

1 Answer 1

30

An unfortunate side-effect of a user merge (Kasra ended up having two different accounts - this happens every now and then) - his employee user type got reset to a "normal" type so his user was not filtered out from the moderator lists.

This has now been fixed (we fired Kasra and removed his diamond from everywhere). To Kasra - sorry you had to find out this way.

There is still residual mod Kasra on the child metas, due to caching (they pick the list from their parent site and cache it for a bit).

19
  • 11
    Poor Kasra, he moves and gets fired.
    – Taryn
    Commented Mar 17, 2016 at 15:48
  • 2
    What about the poor panda here? Also, he still appears on all sites here, but guess it's heavily cached. Commented Mar 17, 2016 at 15:52
  • @ShadowWizard - not getting a panda for his network account. The second list is indeed heavily cached.
    – Oded
    Commented Mar 17, 2016 at 15:56
  • Oh. The accounts tab. Will have to look at that.
    – Oded
    Commented Mar 17, 2016 at 15:57
  • 2
    Maybe it gets fixed if you hire him again?
    – rene
    Commented Mar 17, 2016 at 15:58
  • 8
    @rene - if we do hire him back, he can fix his own damn bugs.
    – Oded
    Commented Mar 17, 2016 at 15:58
  • @Oded no error now, but it also says "no accounts found", and I doubt he chose to hide all account. Also, network profile activity is very lacking, and showing only bunch of badges and very old posts. For example this answer from a month ago is not here. Commented Mar 17, 2016 at 21:00
  • @ShadowWizard - yeah, the network aggregation isn't the best piece of the codebase, and doesn't recover well from merges.
    – Oded
    Commented Mar 17, 2016 at 21:02
  • I see. But will it recover, at some point? Commented Mar 17, 2016 at 21:04
  • @ShadowWizard - that is a very good question... to which I don't have a good answer... yet.
    – Oded
    Commented Mar 17, 2016 at 21:05
  • Count on me to check it again in 6-8 days... ;-) Commented Mar 17, 2016 at 21:06
  • @ShadowWizard - eh. Surely you mean weeks? (please mean weeks)
    – Oded
    Commented Mar 17, 2016 at 21:08
  • Setting ping clock to 23/03/2016 23:10 Commented Mar 17, 2016 at 21:11
  • Still shows up on Code Review Meta meta.codereview.stackexchange.com/users?tab=moderators
    – janos
    Commented Mar 20, 2016 at 20:58
  • @janos - as it does on other child-meta sites, yes.
    – Oded
    Commented Mar 20, 2016 at 21:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .