The day before yesterday I reviewed this suggested edit in the Super User Suggested Edit Review Queue (I have > 2K rep there).  I clicked on “Improve Edit”, made some more changes, and saved (submitted) them.  All the changes were made (both the ones “suggested” by Chema and mine), and the revision history shows two revisions — #5, by Chema, and #6, by me — made at the exact same time.

  • The issue is that revision #5 is shown as having been reviewed by the Community user, with no indication that I did an Improve Edit:


    unlike the normal way it looks when I improve an edit:


  • Also, I looked at my editing stats, and they were the same before and after:

        [Scott has approved 1267 edit suggestions and rejected 750 edit suggestions and improved 289 edit suggestions]
    Normally the third number (improved ___ edit suggestions) would go up by one.

  • Also, it does not appear in my Review history (user profile → “Activity” → “all actions” → “reviews”) or the site’s Suggested Edit history.

This happens on a recurring, but occasional (irregular, irreproducible), basis.  For example, see X, Y, and Z.  I did “Reject and Edit” on all three, but I didn’t “get credit” for X.

  • 1
    How much reputation have you received from edits in the lifespan of your account at that SE?
    – Ramhound
    Mar 19, 2016 at 2:37
  • 2
    Only the first I believe 500 edits gives you reputation (+1000)
    – Ramhound
    Mar 19, 2016 at 2:39
  • 2
    That's not an issue. I'm not talking about reputation; I don't get reputation for suggested edits (because I have > 2K). Besides, look at X, Y, and Z — Y and Z worked correctly after X worked incorrectly. Mar 19, 2016 at 2:39
  • @Ramhound Scott has only 49 suggestions total, anyway. Mar 19, 2016 at 2:59
  • 3
    Yeah; I earned my rep from answers!  So there!    :-)    ⁠ Mar 19, 2016 at 3:03
  • @Ram That's completely unrelated there, OP's talking about reviewing the suggested edit, rather than suggesting themselves.
    – nicael
    Jun 30, 2016 at 16:29
  • hey, look, I found another one, seems to be happening on SO as well
    – m0sa
    Jul 1, 2016 at 11:30
  • 1
    Well, (1) it’s been over a year since I reported this, and (2) almost a year since @nicael diagnosed and independently reproduced the issue.  But (3) it hasn’t been fixed — it happened again just a couple of weeks ago.  And (4) I’m somewhat disappointed to see that I don’t even have a (status_) tag. Jun 24, 2017 at 21:33

2 Answers 2


As others have surmised, there are lots of reasons why you might be able to "improve" a suggested edit without getting credit for it:

  • You could've hit your limit for suggested edit reviews that day
  • You could've somehow gotten review-banned after loading the review task but before submitting the edit
  • The site could've logged you out or expired your token in the brief time between accepting your edit and rejecting your review
  • Your network connection could've died immediately after submitting the edit, thus ensuring the review scripts never got confirmation or were unable to submit the review
  • You could've been sitting at exactly 2000 reputation, and gotten a downvote immediately after your edit went through
  • In the instant following your submission of the edit, a grizzly bear could've torn through the wall of your house, its massive claws shredding your computer like a pile of so much tissue paper, rendering it immediately incapable of executing even the most elegant jQuery

...but as it turns out, none of these crazy scenarios happened to you. Well, at least not in the case of the examples you've provided. The truth is much simpler (and... more embarrassing. For me.)

You took more than 15 minutes reviewing the edits.

The first example came in at about 16 minutes; the second at about 23 minutes. That's not really excessive for a thorough edit, but... We made a little mistake back in 2013: we put in a little check to catch cases where someone was submitting a review late, after the task had already been completed, and put a 15 minute grace-period on it. That is... If you submit a review and the task is already completed and you spent more than 15 minutes between loading the task and submitting the review, your review gets silently thrown away.

Oh right, and the task completes immediately when your edit is made. Which happens before your review is submitted, to allow for validation on your review. Hey, it's suggested edits, it's all a bit hairy.

I've submitted a patch that only discards these reviews if submitted more than 15 minutes after the task was completed, regardless of how long the reviewer spent slaving over a hot editor. That will also address this other long-standing problem.


Update: this could also happen if you have run out of reviewing votes while reviewing in another tab/window/device, and here your "improve and edit / reject and edit" vote wasn't recorded because you have reached your limit for the day.

I'm not 100% it's exactly the problem you're facing, but still.

This does happen when the server fails to get back your fkey. The fkey is your unique identifier, different on each stack, used when you vote, answer, etc, - in other words, do anything which you receive credit for.

Your correct fkey is stored on each page load and resides in StackExchange.options.user.fkey. Funny enough, you could change it temporarily with javascript which would result you not getting the credit for the review or the (review) vote not going through.
BONUS (and proof): try doing StackExchange.options.user.fkey=''. in the console when reviewing. Then submit your review, here's what you get (no "nicael edited" entry).

In case of simply approving or rejecting, you would just get a error, since nobody else takes credit for your action. But in case of improving / rejecting'n'editing, there's also the Community bot which first approves the edit and then tries to give you the credit for review. So, when the Community bot has already approved the edit and the system suddenly realized it doesn't know who were going to do that action (since the fkey is invalid), it just gives the credit to Community again. But! there can't be two reviews by the same user, even the bot, so the "edit" entry isn't recorded at all. However, the edit itself (not the result of review, but the request which changes the question/answer) goes through because it takes the fkey not from the StackExchange object, but seemingly from the following html:

<input id="fkey" name="fkey" type="hidden" value="fkeyGoesHere">

Conclusion: something is messing with JavaScript, specifically StackExchange.options.user.fkey (or probably the whole StackExchange object). This could happen either because of the corrupted page load or some extensions you have installed.

Anyway, it hasn't been fixed yet:

  • 1
    Thanks for (1) understanding what I’m saying, (2) identifying a possible mechanism, and (3) finding a way to reproduce the symptom.  I don’t “mess with JavaScript” (or, at least, very rarely, and never to manipulate the StackExchange object) and I don’t have any extensions loaded.  But I’m running Internet Explorer 11 on Windows 7, and I do have occasional problems with what could be called corruption on the web.  For example,  … (Cont’d) Jun 30, 2016 at 19:30
  • (Cont’d) …  I never log out of Stack Exchange, but sometimes it “forgets” that I’m logged in, and asks me to Identify & Authenticate again.  I consider a bit of instability to be normal behavior with Windows, but I’ll try to remember to notice whether my problem in the review queue is correlated with generally flaky behavior in other applications (and other browser tabs). … … … … … … … … … … … … … … … … … … … … … … P.S. Just out of curiosity, does this mean that it would be straightforward for somebody to give somebody else credit (and/or blame) for his actions (or, at least, edits)? Jun 30, 2016 at 19:31
  • 1
    You mean, do an action and give the credit for it to someone's else, right @Scott? That's not easy to guess someone's fkey, but probably it should be possible.
    – nicael
    Jun 30, 2016 at 22:19
  • 4
    checked that possibility, OP's fkey (and IP) didn't change between requests
    – m0sa
    Jul 1, 2016 at 10:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .